[Bug 12637] Re: LCD Brightness on Laptop Always Set Very Low at Boot

Richard Green rtg at aapsc.com
Wed Feb 13 07:38:34 UTC 2008


Here's some more info.  I went to system/administration/services, and disabled gdm, thinking I'd reboot to a console, just to see if this was a kernel problem, or possibly an xorg problem, since it's happening just milliseconds before the screen blanks to switch to X.
  Well, that wasn't clean at all!  it kills gdm immediately, which blew away my X session, as well as all the apps running, leaving me at a very ugly console with a huge font, reminiscent of my old commodore VIC-20.
I managed to reboot, and it did come up without X, but with the same ugly huge font, so I only saw about 10 lines of text, and my prompt was somewhere below the bottom of the screen, so I was typing blind.  
  ...but the important part is that the screen dimmed, so this is definitely NOT an X issue, it's in the kernel.  I also focussed my eyes at the top of the screen during the boot, and I was able to see that the [PCI} allocation... error that was displayed there came up DIM, just before the screen blanks, so the actual sequence is something like this:
'Kernel is alive'
'kernel mapping tables...'
(backlight goes to dim)
'[PCI] allocation'... 

<rant>
Once I logged in at the console, I ran startx, and was able to get my desktop.  I again went to system/administration/services and re-enabled gdm, which AGAIN took immediate action, which in this case tried to start a second X server, which failed once, but eventually succeeded (as :1), leaving me at the gdm prompt.  I have no idea which virtual console I was on, but ctrl-alt-f7 got me back to the X session.  I probably should file a bug elswhere for this usability issue...  Or just go back to school.  In this new age of upstart, how do I cleanly do a one-time reboot to a normal console?  On my old redhat or suse systems, I always had runlevel 3, but I discovered a while back that in ubuntu runlevel 3 is the same as runlevel 5, and now with upstart, I have no idea if 'runlevels' even exist anymore, and if they do, how to configure and specify them?  System/administration/services certainly has no visible 'runlevel-like' distinctions, /etc/inittab is gone  grrr...
  There is no 'upstart' directory under /etc.  There is no upstart manpage.  Where do I look for clues?  `man init` is still there. scroll to the bottom, its author is Scott James Remnant.  So he calls the project upstart, but the binary is still init, just to confuse us, right?  
  OK, the manpage mentions /etc/event.d.  Go browse...  rc-default seems to fall thru to runlevel 2.  Looking at the /etc/rcn.d directories, I find that runlevel 1 would not start X, but all others 2 - 5 do.  So I can probably edit one of those other directories to create a multiuser without X runlevel, but I still don't know how to pass a one-time parm thru grub to select that level.  More studying to do, and I'm tired.  I'm going to bed now...
</rant>

-- 
LCD Brightness on Laptop Always Set Very Low at Boot
https://bugs.launchpad.net/bugs/12637
You received this bug notification because you are a member of Kernel
Bugs, which is a direct subscriber.




More information about the kernel-bugs mailing list