[Bug 88746] Re: ehci_hcd module causes I/O errors in USB 2.0 devices

zasq saskia.mestern at hamburg.de
Thu Dec 11 23:53:48 UTC 2008

Hi friends,

it really seems hard to really track down the problem. I tried out quite
a few tricks and tweaks out of several forums but unfortunately never
really took the time to test the single changes and sort out what helped
and what didn't. Let's see what I can remember:

1. The USB-connections on my laptop never were perfect, not with feisty,
gutsy nor hardy. And not with intrepid. I am very sure that it has to do
with the chipset. I don't know how to find out if my ATI-chipset in fact
is an Alcor-chipset as Troy J suggests. But I remember that - when I got
my Dell almost 2 years ago - I also had the problem with windows vista
(I still have a dualboot system, but don't use windows anymore). Back
then, Dell sent me some patches for the USB-connections and - strange
thing - after applying them, the usb-devices that didn't mount before,
could be used in BOTH windows and Ubuntu. The memory-stick worked fine,
the printer (which had to deal with bigger files) was always buggy. (I
didn't have the WD Ext. HD back then). Half a year ago I did a complete
reinstall without those Dell-patches, but everything still worked fine.
Maybe the patches had to do with the BIOS and are therefore still

2. Some weeks ago I updated my bios to 2.6.3. I think (but am not sure
if it is because of this updating) that after that the mounting of the
devices was less buggy. The initial mounting (plug and play) at least
works fine now. I also applied the "autosuspend" -1 trick mentioned
above by Andrew. That reminds me that I read somewhere that the problem
of sudden crashes or self-unmounting (or whatever you would call that)
of usb-devices could also have to do with the power management.... As I
am no expert in these things, in the past I didn't put attention to the
I/O error messages and didn't know about ehci, so I can't say what
changed there. Sorry!

3. As mentioned, now the problem remains that all the devices crash once
in a while when confronted with big transfer loads. In that case I have
to restart the system. It has also happened that I plugged a device in
again after a long time (with no restart inbetween) and it would mount
again normally. But usually I can't wait for long minutes or hours, so I
restart the system.

4. If you take a look at my lsusb and lsusb -vv output (see attached
file), there are six usb-devices listed. Nevertheless, the laptop only
has four usb-ports (two in the back being Bus003 and Bus004 and two on
the right lateral being Bus002 upper port and Bus001 lower port). All
these should be USB 2.0 ports but all are filed as 1.1 ports. I have no
idea what the other two ports are (one of them being listed as 2.0)!!!
As the ports are already listed as USB 1.1 the "echo 128"-thing wouldn't
make sense, right? The question is how I can get the ports to be
recognized as USB 2.0!

Please let me know what information I can provide to help solve the
problem. And remember: I'm no computer expert :)

All the best,


** Attachment added: "lsusb and lsusb -vv"

ehci_hcd module causes I/O errors in USB 2.0 devices
You received this bug notification because you are a member of Kernel
Bugs, which is subscribed to Linux.

More information about the kernel-bugs mailing list