[Bug 88746] Re: ehci_hcd module causes I/O errors in USB 2.0 devices

Andy Rabagliati andyr at wizzy.com
Wed Dec 10 06:20:39 UTC 2008

I have a feeling there are two different bugs here. All these filesystem
comments, and "echo 64 > /sys/block/sdh/queue/max_sectors_kb" make no
sense to me, as often the device (/dev/sdh or whatever) has not even
come up.

I tried formatting my USB stick as ext2 - but it makes no difference.

As mentioned earlier, *my* bug is a boot-time interaction between
ehci_hcd and my Alcor Micro Corp card reader - I think the only USB 1.X

I have tried a PCI addin card with two USB ports - ( ALi Corporation USB
1.1 Controller // ALi Corporation USB 2.0 Controller ) - an old piece of
hardware that works fine elsewhere - drives don't work there either if
the Alcor card-reader is plugged in.

It could be an interaction between the Alcor and the Intel Corporation
82801G (ICH7 Family) USB UHCI Controller - it has a 9 pin header that I
can't plug into the Ali Corp card.

My solution is simply to unplug the Card reader - if I need it I can
plug it in after boot. Everything works fine then.

I have tried loading the USB modules in a different order - it makes no

ehci_hcd module causes I/O errors in USB 2.0 devices
You received this bug notification because you are a member of Kernel
Bugs, which is subscribed to Linux.

More information about the kernel-bugs mailing list