[Bug 275998] Re: audio recording very silent

Rocko rockorequin at hotmail.com
Wed Dec 10 01:48:27 UTC 2008

Isn't this an ALSA bug rather than a PulseAudio bug?

In Hardy, I could change my XPS 1530's built-in microphone recording
volume via the control named 'Digital' in the gnome-volume-control
'Recording tab' (you have to enable it first via the preferences
window). But in Intrepid there is no such control.

In Hardy, I can see this control in the /var/lib/alsa/asound.state file:

	control.32 {
		comment.access 'read write user'
		comment.type INTEGER
		comment.count 2
		comment.range '0 - 120'
		comment.tlv '0000000100000008fffff44800000032'
		iface MIXER
		name 'Digital Capture Volume'
		value.0 120
		value.1 120

but this control is missing in Intrepid's /etc/asound.state file (which
is created when I run /etc/init.d/alsa-utils start) and
/var/lib/alsa/asound.state file.

This is with alsa 1.0.17. Hardy uses alsa 1.0.16.

I've also tried alsa 1.0.18
(http://ubuntuforums.org/showthread.php?t=962695) in Intrepid and it
doesn't detect the capture volume either.

audio recording very silent
You received this bug notification because you are a member of Kernel
Bugs, which is subscribed to Linux.

More information about the kernel-bugs mailing list