[Bug 54273] Re: USB device not accepting address: error -110

chrono13 chrono13 at gmail.com
Tue Dec 9 16:36:37 UTC 2008

A solution (increasing the timout) per Mario Italo, bug 261710 worked
for me.

1. Always back up config files before editing them:
sudo cp /etc/modprobe.d/options /etc/modprobe.d/options.backup1
Now open /etc/modprobe.d/options in write mode:
sudo gedit /etc/modprobe.d/options

2. Add the line:
options scsi_mod inq_timeout=20
and save the file.
Seemingly reloading the module (scsi_mod) does not cause the new configuration to take hold. What worked for both he and I was to reinstall the kernel.

3. Type uname -a and take note or memorize the exact kernel version
numer you are using.

4. Use the above kernel number to reinstall your kernel. For me it was:
sudo aptitude reinstall linux-image-2.6.27-7-generic
This will take a couple of minutes.

5. Reboot and test. This fixed it for Mario and has worked great for me.
Note that there is probably a better way to make the new configuration
take effect other the reinstalling the kernel. Whoever knows what that
is could post that and we would have a better solution.

This confirms that the bug is just that the device does not wake up
quickly enough. These instructions are for anyone who has these key(s)
and is receiving the -110 (and possibly other) errors while attempting
to use them.

A test to see if the above fix will fix your problem is to insert the
key, and shut down the machine. Start it back up, if it recognizes the
drive and mounts it (or lets you mount it), then the above steps should
fix the bug and allow you to use the key normally.

Good luck, and thanks again to Mario Italo.

Solution originally found in report of bug 261710 (Corsair Flash Voyager 8GB USB key causes device descriptor read/64, error -110)
Posted this solution to bug 54273 (USB device not accepting address: error -110)

USB device not accepting address: error -110
You received this bug notification because you are a member of Kernel
Bugs, which is subscribed to linux-source-2.6.15 in ubuntu.

More information about the kernel-bugs mailing list