[Bug 238549] Re: xen dom0 crashes with "BUG: soft lockup - CPU#0 stuck for 11s!"

Alex Dehnert alex-net.url.net.launchpad at dehnert.arctic.org
Sun Aug 10 07:27:36 UTC 2008

I think I may have seen the same bug. At least, the Xen dom0 will
occasionally completely freeze up. Moving the mouse  does not cause the
cursor to move in X11, pressing keys doesn't produce any visible result
(in X11 or console), ssh sessions freeze up (to host and guest), other
services are not responded to, and so forth. I haven't tried SysRq,
though I will next time it goes down.

Nothing appears in the log files (that I've seen).

I haven't figured out a reliable way to reproduce the problem. However,
it does seem to happen more when doing disk intensive operations (eg,
rebuilding a RAID array).

I've been seeing this problem fairly frequently since around when I got
home for the summer and upgraded to 8.04 and installed ubuntu-desktop
(previously, the machine was only serving as a server). I don't recall
hitting the issue before the upgrade, but I may be mistaken.

The bug occurs with 2.6.24-18-xen and 2.6.24-19-xen, although does not
seem to occur when using the non-Xen kernels (admittedly, while I've
tried to stress the non-Xen kernels, without a reliable way to cause the
bug I'm not sure that means it isn't there, and I've used the Xen
kernels much more).

Let me know if there is a way to attach several files to one comment. I
don't see one, so I'll submit a few more comments.

Also, please let me know if you need anything else.

** Attachment added: "dmesg.log"

xen dom0 crashes with "BUG: soft lockup - CPU#0 stuck for 11s!"
You received this bug notification because you are a member of Kernel
Bugs, which is subscribed to linux-meta in ubuntu.

More information about the kernel-bugs mailing list