[Bug 223199] [NEW] fglrx does not load

Martin Stolle martin at stolle.name
Sun Apr 27 18:31:10 UTC 2008

Public bug reported:

Binary package hint: linux-restricted-modules

After rebooting my system, X, configured to use fglrx, is very slow.

After some debugging, it looks like the fglrx kernel module was not
loaded.  Trying to manually modprobe is results in:

"Could not open '/lib/modules/2.6.24-16-generic/volatile/fglrx.ko"

In order to try to troubleshoot this, I ran "sudo depmod" and tried
modprobe again (with -v):

"install /sbin/lrm-video fglrx"
"FATAL: Error running install command for fglrx"

looking at /sbin/lrm-video, it just runs modprobe --ignore-install, so
tried that myself:

"FATAL: Module fglrx not found"

Weird...  so I try reinstalling the package (apt-get remove --purge,
apt-get install)

AHA! now "modprobe fglrx" works.  Let's see what happens after a

Again... no fglrx loaded.  Trying to modprobe it:

"FATAL: Could not open
'/lib/modules/2.6.24-16-generic/volatile/fglrx.ko': No such file or

What's going on?  It looks like there's a bug in linux-restricted-
modules that makes the fglrx driver disappear after a reboot.  Looking
further into it, /lib/linux-restricted-modules/2.6.24-16-generic/
contains a bunch of modules, but only a few of them show up in
/lib/modules/2.6.24-16-generic/volatile'.  After a fresh package
reinstall all of them are there but after a reboot, only some of them
are.  How come?


** Affects: linux-meta (Ubuntu)
     Importance: Undecided
         Status: New

fglrx does not load
You received this bug notification because you are a member of Kernel
Bugs, which is subscribed to linux-meta in ubuntu.

More information about the kernel-bugs mailing list