[Bug 96733] Re: 6.06.1 Install fails on HP ML 350G5 with kbdmode hanging

Josué Alcalde González josuealcalde at gmail.com
Tue Sep 11 20:59:37 UTC 2007

*** This bug is a duplicate of bug 55495 ***

Sorry, perhaps I haven't explain correct.

I also have and IDE CDROM, USB also works and I don't need HP VIrtual
Keyboard or iLO or whatever it is. I have the same server, the same

It is better to tell you my sad history with this machine and its happy
end :)

1. I had to install Ubuntu 6.06 in a HP ML-350 G5 (I usually install a complete ubuntu with gnome because people in my work doesn't know too much about linux and sometimes they must use it, and it is also easy for me).
2. I tried live CD and it hangs in "keyboard layout" step.
3. Dapper is the first Ubuntu with ubiquity and it was also the first time I install ubuntu for 64 bits, so I tried alternate CD. Of course, it also hangs in the same step. 
4. I tried different keyboards usb/ps2 and of course, it did not work. 
5. Then, I found the kbd-chooser process in a D state and found this bug.
6. Then, I install it using expert mode but something went wrong because any step asked me for the user name so I tried using "Rescue Mode"
7. Then, I found the problem in bug #55495 with a loop in a kernel module and a lot of messages in console. Using "Rescue Mode" shows you al the messages from the kernel in console (a problem when there is a loop). It could be solved removing the uhci_hcd module, but you lost usb. It was not a big problem because it was solved in a new kernel, but you can not update the kernel in your instalation cd. The best workaround, lost your usb removing the module until you install and update your kernel.
8. As my installation was a little broken, I did not have a user to login and rescue mode was unusable because messages were flooding my consoles, I started again with the live cd. 
9. I had the idea to remove uhci_hcd and try ubiquity again and it worked perfectly (of course, i had not usb support during installation).
10. Once it was installed, I update my kernels and the problem was off.

So then, my conclusions were:
1. There is no problem with kbd-chooser, it is a loop in a kernel module which causes a hang in kbd-chooser.
2. This bug already exists as 55495
3. This bug is already solved but the state is triaged because of old kernel in instalation cds.
4. There is a workaround to install dapper, remove the uhci_hcd until you install and update your kernel

6.06.1 Install fails on HP ML 350G5 with kbdmode hanging
You received this bug notification because you are a member of Kernel
Bugs, which is a bug contact for linux-source-2.6.15 in ubuntu (via bug

More information about the kernel-bugs mailing list