[Bug 159557] Re: NFSv3 in Gutsy maps uids wrongly

barenakeddali bd.dali at gmail.com
Sun Nov 18 10:33:31 UTC 2007


I also have problems mounting rw using NFS3, Gutsy client mounting from
CentOS 5 NFS server.

fstab:
scaleo:/filer/temp /mnt/scaleo/temp nfs rw  0 0

sudo mount -a, check /etc/mtab:
scaleo:/filer/temp /mnt/scaleo/temp nfs rw,addr=<IP manually removed> 0 0

Can't write to /mnt/scaleo/temp, try checking with nfsstat -m:
/mnt/scaleo/temp from scaleo:/filer/temp
 Flags: ro,vers=3,rsize=32768,wsize=32768,hard,proto=tcp,timeo=600,retrans=2,sec=sys,addr=scaleo

Note "Flags: ro", according to mtab it's rw.

Tried the exact same setup from a CentOS client and it worked.

Added nfsvers=2 to fstab:
scaleo:/filer/temp /mnt/scaleo/temp   nfs   rw,nfsvers=2    0 0

Remounted, check mtab:
scaleo:/filer/temp /mnt/scaleo/temp nfs rw,nfsvers=2,addr=<IP manually removed> 0 0

And nfsstat -m:
/mnt/scaleo/temp from scaleo:/filer/temp
 Flags: rw,vers=2,rsize=8192,wsize=8192,hard,proto=tcp,timeo=600,retrans=2,sec=sys,addr=scaleo

Hey, now it's rw. Verified that I can write to the share, works.

Looks like there is a problem with NFSv3 in the Gutsy NFS client. Tried
manually mounting (skipping fstab), same result.

-- 
NFSv3 in Gutsy maps uids wrongly
https://bugs.launchpad.net/bugs/159557
You received this bug notification because you are a member of Kernel
Bugs, which is a bug contact for linux-meta in ubuntu.




More information about the kernel-bugs mailing list