[Bug 38263] Re: freeze at startup

robokiller theagentsrcumming at hotmail.com
Sun Nov 18 00:25:32 UTC 2007

I had the exact same problem and i managed to fix it by randomly changing my PCI-Express BIOS settings
I spent weeks trying to figure out why it was freezing loading ubuntu, even from the livecd, then i tried unpluging my pci-express card and pluging in the integrated graphics and it worked! so i thought it was my graphics card (ati) so i changed it for my mums just to test it but still locked up. so i thought.. must be a pci-express problem.

heres how i fixed it.

1. restart and go into the BIOS settings (usually F2 or del)

2. go to the advanced options > Chipset Configuration > PCI Express

3. then disable the option 'Compliance Test Pattern

4. you may still get the 
4294671.433000] PCI: Cannot allocate resource of region 3 of device 0000:00:00.0
[4294671.433000] PCI: Cannot allocate resource of region 3 of device 0000:01:00.0
[4294671.433000] PCI: Cannot allocate resource of region 0 of device 0000:02:00.0

errors flicker on the screen but at least mine booted and worked sweet
after i did that

hope it helped

freeze at startup
You received this bug notification because you are a member of Kernel
Bugs, which is a direct subscriber.

More information about the kernel-bugs mailing list