[Bug 34551] Re: scanimage not accessing epson perfection 2450

David Fletcher forums at fletchersweb.net
Thu Jun 14 21:16:57 UTC 2007

This model of scanner is known to be a problem to both myself and
others. I was using FC5 until recently, where it is also a problem.

At present, I'm using Feisty, and I've just done a nice looking scan of
a 35mm transparency using my Perfection 2450.

Firstly, and this seems to be of the utmost importance with this
particular scanner, DON'T try to use it with USB2.0. It just doesn't
work. In my experience, it can be made to work with USB1.1 but most
computer users don't have this available these days. I'm beginning to
suspect that there's something wrong with the USB2.0 implementation in
the scanner itself. The way to make it work is to use the Firewire
connection. Go buy a Firewire cable if you've not got one, and a
Firewire expansion card if you've not got a socket on the motherboard.
Just doing this gets it working with FC5, but it's not enough with

My path of reasoning was as follows:-

Upon installing Kubuntu (I tried Dapper first) I noticed that it appears
to be organised with group access control to various hardware devices
such as CDROM drives, USB flash drives and scanners. Membership of these
groups appears to be granted to users to enable them to use these
devices by default in Feisty, but I think they had to be added manually
in Dapper.

An email acquaintance in New Zealand I contacted because of this scanner
told me that what he does is find out the device name, then do chmod 666
to get it working. As I said to him last night, this seems to me to be a
bit of an unsubtle approach.

So what I did last night was try to find out how to get sane-find-
scanner working, given that Feisty definitely creates an entry in /dev/.

sane-find-scanner does not find the 2450 when run as a normal user. So I did
su - adminaccountname
and tried again. It still didn't work. Finally tried
sudo sane-find-scanner as adminaccountname to run it as root, and this time it worked. The scanner was reported as being found at /dev/sg3. My friend in New Zealand reports that his 2450 appears at /dev/sg2.

Checking the permissions on this device shows ownership to be root:root!
Which is why it doesn't work.

sudo chown root:scanner /dev/sg3
sets the permissions to the correct values on my computer, and now I can use xsane as a normal user to run the scanner. It worked for me last night, and it's worked for me again this evening. It's just scanning a second slide as I type this, so in my humble opinion I've found the problem.

Now, it needs to be fixed.

I'm not a Linux expert, so I can't say for certain, but is the ownership
of devices set up by udev?

Wherever the problem is, somebody please fix it. It's a PITA and an
embarrassment and we can't expect new users to jump the chown hoop when
they've just decided to give Linux a try instead of Windows.

scanimage not accessing epson perfection 2450 
You received this bug notification because you are a member of Kernel
Bugs, which is a direct subscriber.

More information about the kernel-bugs mailing list