[Bug 62995] Re: Linux doesnt support ENE CB-712 SD card reader

Jonáš Svatoš freetekno23 at gmail.com
Tue Jul 10 19:42:51 UTC 2007


Download the patch above to your home directory
sudo apt-get update
sudo apt-get install kernel-package libncurses5-dev fakeroot bzip2 linux-source
tar -xjvf /usr/src/linux-source-$(uname -r)
cd linux-source-$(uname -r)
patch -p1 < ../linux-source-2.6.20_ene_cb712.patch
make menuconfig  <--- Exit, Save ( As you propably don`t want to change anything)
make-kpkg clean
fakeroot make-kpkg --initrd --append-to-version=-custom kernel_image kernel_headers
cd ..
sudo dpkg -i linux-headers-*.deb
sudo dpkg -i linux-image-*.deb
sudo reboot

And that`s it, you should boot into your custom patched kernel and card reader should be working.
If anything goes wrong, just select unpatched kernel in GRUB.
And one more thing, if you have any hardware witch needs linux-restricted-modules, 
(like ATI and Nvidia cards, Atheros wifi adapter) you have to download and compile sources by yourself (they need to be linked against the patched kernel)

Yes, i`ve tested it with 1gb card, because i have only one.)

Linux doesnt support ENE CB-712 SD card reader
You received this bug notification because you are a member of Kernel
Bugs, which is a bug contact for linux-meta in ubuntu.

More information about the kernel-bugs mailing list