[Bug 50813] Re: 2.6.15-xx ppc kernel fails to boot on G4

Mike michael at hammill.name
Fri Sep 22 18:13:09 UTC 2006

Well, it took some time to get those Ubuntu official CDs.   I get the
exact same error (non-booting Kernel) on both a G4 (which is running
Ubuntu 6.06 with an old 2.6.12-10-powerpc Ubuntu Kernel) and a G3 (B&W)
which is running Ubuntu server (2.6.12-10-powerpc Ubuntu Kernel) when I
boot up with the official CDs and the default Kernel.

While waiting for those official CDs, I have tried the interim Kernels provided by 6.06, namely:
(possibly others, but those are the only ones still around under /boot),
but it's the same story.  

It's a pain to try these then have to boot off an old Ubuntu CD to point
vmlinux.old and initrd.img.old to my old 2.6.12-10-powerpc kernel.  I
find it totally remarkable that no one else has encountered this.   I
have a similar B&W G3 running FC5 Kernel 2.6.17-1.2157_FC5, and a
similar G4 running Gentoo Kernel 2.6.17-gentoo-r4 so I know the kernel
is not "beyond" the hardware.

I tried using "Linux debug" with the Ubuntu Official CDs when letting it
take the default didn't work, but that didn't make any difference.  Is
there some way to get more information to figure out what is going on?

Hope you can shead some light.  I really like Ubuntu, and would like to
keep using it.

Best regards,
Mike Hammill

2.6.15-xx ppc kernel fails to boot on G4

More information about the kernel-bugs mailing list