[Bug 43961] Re: Power down after shutdown does not work...

Michael Kofler michael.kofler at gmx.com
Thu Sep 7 15:27:39 UTC 2006

I had the same problem, i.e. after 'will now halt' the computer won't
actually halt.

The solution for me was acpi=off!

Hardware is a PC with ADM Duron 1300, the BIOS from 2001 says it
supports ACPI.

dmesg says:

> dmesg | grep -i acpi
[17179569.184000]  BIOS-e820: 000000004fff0000 - 000000004fff8000 (ACPI data)
[17179569.184000]  BIOS-e820: 000000004fff8000 - 0000000050000000 (ACPI NVS)
[17179569.184000] ACPI: RSDP (v000 AMI                                   ) @ 0x000fa340
[17179569.184000] ACPI: Unable to map RSDT
[   39.585043] ACPI: Subsystem revision 20051216
[   39.585049] ACPI: Interpreter disabled.
[   39.585070] pnp: PnP ACPI: disabled

I tried acpi=force, then switched to a i386 kernel. Both didn't help.

Then I found out that for some reason, the apm kernel module gets always
loaded, no matter whether I use ACPI or not. The apm module is even
loaded when I start the kernel with the option apm=no and with an
additional line 'blacklist apm' in /etc/modprobe.d/blacklist. (Why is

De-installing apmd is no option, because ubuntu-desktop depends on it
... (Why?)

OK, as I couldn't get rid of APM, I tried to get rid of ACPI.

Then I also tried acpi=off, because I thought, apm and acpi might
somehow disturb each other. Bingo!

For reference:

> uname -a
Linux mars 2.6.15-26-386 #1 PREEMPT Thu Aug 3 02:52:00 UTC 2006 i686 GNU/Linux

It seems to me, that somehow apm and acpi disturb each other.

PS: I also tried the apm options power_off=1 and realmode_power_off=1,
but these options didn't change anything on my machine. With ACPI
(partly) on, they don't help. With ACPI off, they are not needed.

Power down after shutdown does not work...

More information about the kernel-bugs mailing list