[Bug 63882] linux-2.6.18 build fails with incorrect version in deprecated 'version.h'

klauskiwi klauskiwi at gmail.com
Wed Oct 4 01:13:03 UTC 2006


Public bug reported:

Binary package hint: kernel-package

This bug is related to kernel-package 10.049ubuntu4

Steps to reproduce:
1) untar linux-2.6.18.tar.bz2
2) cd linux-2.6.18
3) make-kpkg --rootcmd fakeroot --initrd --revision 1 kernel_image modules_image

after a while, the build process fails with
------------------cut-here----------------------------------------------
====== making target install/linux-image-kdump [new prereqs: ]======
This is kernel package version 10.049ubuntu4.
echo "The UTS Release version in include/linux/version.h"; echo "     \"\" "; echo "does not match current version:"; echo "     \"2.6.18\" "; echo "Please correct this."; exit 2
The UTS Release version in include/linux/version.h
     "" 
does not match current version:
     "2.6.18" 
Please correct this.
make: ** [install/linux-image-kdump] Erro 2
-------------------cut-here----------------------------------------------
The problem seems similar to http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=355147
but with this new target 'linux-image-kdump'.

Problem did not happened before in Dapper release (same kernel, same
dir, same command)

** Affects: kernel-package (Ubuntu)
     Importance: Undecided
         Status: Unconfirmed

** Summary changed:

- linux-2.6.18 build fails with incorrect version in deprecated 'version.h'
+ [edgy] linux-2.6.18 build fails with incorrect version in deprecated 'version.h'

** Description changed:

  Binary package hint: kernel-package
+ 
+ This bug is related to kernel-package 10.049ubuntu4
  
  Steps to reproduce:
  1) untar linux-2.6.18.tar.bz2
  2) cd linux-2.6.18
  3) make-kpkg --rootcmd fakeroot --initrd --revision 1 kernel_image modules_image
  
  after a while, the build process fails with
  ------------------cut-here----------------------------------------------
  ====== making target install/linux-image-kdump [new prereqs: ]======
  This is kernel package version 10.049ubuntu4.
  echo "The UTS Release version in include/linux/version.h"; echo "     \"\" "; echo "does not match current version:"; echo "     \"2.6.18\" "; echo "Please correct this."; exit 2
  The UTS Release version in include/linux/version.h
       "" 
  does not match current version:
       "2.6.18" 
  Please correct this.
  make: ** [install/linux-image-kdump] Erro 2
  -------------------cut-here----------------------------------------------
  The problem seems similar to http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=355147
  but with this new target 'linux-image-kdump'.
  
  Problem did not happened before in Dapper release (same kernel, same
  dir, same command)

** Tags added: 2.6.18 build kernel kernel-package utsrelease
utsrelease.h version.h

-- 
[edgy] linux-2.6.18 build fails with incorrect version in deprecated 'version.h'
https://launchpad.net/bugs/63882




More information about the kernel-bugs mailing list