[Bug 50031] Edgy on A20m "almost" works (Re: [regression] Suspend [to-RAM and to-disk] is broken in 2.6.15-25.43)

Peter Whittaker pwwnow at gmail.com
Sun Nov 26 16:33:08 UTC 2006


On Fri, 2006-24-11 at 13:35 +0000, Peter Whittaker wrote: 
> ThinkPad A20m running 2.6.17-10-33, all stock, no special patches
> or packages (FWIW, HWDB 2ad3fb6ba7d8b4d771bf8186b697277f).
> 
> To workaround the problems described above, I've tried booting
> with various combinations of
> 
>     noapic, nolapic, and pci=noacpi
> 
> and various combinations of
> 
>     ec_intr=0, lapic, and pci=noacpi
> 
> all with ACPI=force.
> 
> I haven't yet tried adding pci=noacpi to the second combo set, i.e.,
> with ec_intr=0 and pci=routeirq... ...one exception is that sound
> was OK upon resume when I booted with noapic and pci=noacpi

Update: Booting with ACPI=force and ec_intr=0, I've now tested all
combinations of pci=noacpi, pci=noacpi, and noapic (that is, I use
ACPI=force and ec_intr=0 on all boots, and booted with the 7
combinations).

Result: Six out of the seven combinations work the same as described in
my 'Edgy on A20m "almost" works' report, above. That is, S3 and S4 work,
resume works, but upon resume, video playback is blocky and the network
wakes up "late".

One combination made things worse: When I boot with "acpi=force
ec_intr=0 pci=noacpi", the system become unresponsive upon resume from
S3 sleep. Load average spiked at 15, was never lower than 7, and typing
was painful. I had to BRS (big red switch). Good thing Evolution has a
recovery feature, otherwise I would have lost most of this report....

To summarize:

	ThinkPad A20m "likes" 2.6.17-10-386 and "likes" ACPI:
	"Almost everything" works, there are couple of things
	that don't work	after a resume, as described above,
	and the system seems more responsive under ACPI than
	under APM, at least until the first S3. Upon resume,
	system responsiveness seems about the same with both
	ACPI and APM.

One last misc note: On the A20m, booting with lapic disables APIC. The
BIOS disables lapic (hadn't realized this until yesterday), and when I
boot with lapic , there is a message in the kernel log that Linux was
unable to initialize APIC.

-- 
[regression] Suspend [to-RAM and to-disk] is broken in 2.6.15-25.43
https://launchpad.net/bugs/50031




More information about the kernel-bugs mailing list