[Bug 37066] [r8187] Netgear WG111v2 Wireless USB Adapter recognized but not functioning

Konstantinos Togias ktogias at math.upatras.gr
Thu Nov 2 01:32:17 UTC 2006

Public bug reported:

I tried Netgear WG111v2 Wireless USB Adapter with Dapper Flight 5
(kernel 2.6.15-18-386).

When I plug WG111v2 into a usb port, r8187 module is loaded. I can see
wlan0 interface with iwconfig wlan0. But the led on the adapter does not

Then I run iwlist wlan0 scan and get:
wlan0     Failed to read scan data : Operation not permitted

If I then run dhclient wlan0, dhclient fails to contact my dhcp server,
but just after that iwlist wlan0 scan command manages to scan and detect
my Access Point. It reports Signal level:0.

After that running dhclient fails to obtain an ip and even if i give a
static ip the adapter fails to transmit any data. The same happens when
configuring wlan0 through network-admin gui.

The specific adapter is not detected at all under breezy but works
flawlessly with ndiswrapper under breezy.

I attach below the output of lshw, lsusb, lsmod, iwconfig, iwlist,
dhclient and ifconfig.

Note: the original reporter indicated the bug was in package 'nic-usb-modules-2.6.15-18-386-di'; however, that package was not published in Ubuntu.

** Affects: linux-source-2.6.15 (Ubuntu)
     Importance: Medium
         Status: Needs Info

[r8187] Netgear WG111v2 Wireless USB Adapter recognized but not functioning

More information about the kernel-bugs mailing list