[Bug 45834] [Regression] xshm flickers with kernel 2.6.15-23

Alan Tam Tam at SiuLung.com
Sun May 21 06:40:26 UTC 2006


Public bug reported:

This bug occurs with linux-image-2.6.15-23 but not linux-
image-2.6.15-22.

Due to bug 32963, I cannot play videos using Xv. I tried all backends
xine supports, and only xshm showed correct colors and was smooth
enough. With a new kernel upgrade, videos do not play well anymore. They
seem to play at a very low frame rate, like <10fps.

I hope this bug is easy enough to be fixed for Dapper, since it is
introduced just recently.

Motherboard is Foxconn 945G7MA-8EKRS2. Monitor is LG L1950S. Xorg driver
is i810.

sltam at beech:~$ sudo lspci -v
...
0000:00:02.0 VGA compatible controller: Intel Corporation 945G Integrated Graphics Controller (rev 02) (prog-if 00 [VGA])
        Subsystem: Foxconn International, Inc.: Unknown device 0cc0
        Flags: bus master, fast devsel, latency 0, IRQ 193
        Memory at fdf00000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at ff00 [size=8]
        Memory at d0000000 (32-bit, prefetchable) [size=256M]
        Memory at fdf80000 (32-bit, non-prefetchable) [size=256K]
        Capabilities: [90] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-
        Capabilities: [d0] Power Management version 2
...

** Affects: linux-source-2.6.15 (Ubuntu)
       Severity: Normal
       Priority: (none set)
         Status: Unconfirmed

-- 
[Regression] xshm flickers with kernel 2.6.15-23
https://launchpad.net/bugs/45834




More information about the kernel-bugs mailing list