[Bug 44911] Broadcom wireless: ifconfig eth1 up result in hard-lockup

Andy Brook javahollic at gmail.com
Mon May 15 22:14:33 UTC 2006

Public bug reported:

Binary package hint: bcm43xx-fwcutter

Im using a HP pavillion zv5383EA, AMD64 laptop.  It has a broadcom
wireless chipset.  It worked under Breezy (after a fasion) using
ndiswrapper and wpa_supplicant.  In Dapper, it has never worked.  There
seems to be support for the bcm43xx, and involved in that is the
downloading of microcode via the bcm43xx-fwcutter script.

I can use iwconfig to list wireless device at eth1, however, executing
'ifconfig eth1 up' causes a total hardware lockup - every time.  If the
microcode isnt applicable to my card, surely it shouldnt have been
'loaded'? and if it is the right code, why the hard lockup?

Ive been hoping this would go away with the 150+ daily updates but it
hasnt yet, including a kernel update (in windows - wireless! so cant dig
out kernel image #).

If the fwcutter is working for other people, maybe I need to get
ndiswrapper out again and try my luck, but I cant help think it should
detect incompatible cards and warn somehow.

How does ifconfig cause a hardware lock anyway!

** Affects: linux-source-2.6.15 (Ubuntu)
       Severity: Normal
       Priority: (none set)
         Status: Needs Info

Broadcom wireless: ifconfig eth1 up result in hard-lockup

More information about the kernel-bugs mailing list