[Bug 32182] Mounting of USB storage fails

Tapio Vaattanen tav at iki.fi
Wed May 10 12:59:21 UTC 2006

Public bug reported:

Affects: hal (upstream)
       Severity: Unknown
       Priority: Unknown
         Status: Unknown
Affects: linux-source-2.6.15 (Ubuntu)
       Severity: Normal
       Priority: (none set)
         Status: Rejected
Affects: hal (Ubuntu Breezy)
       Severity: Normal
       Priority: (none set)
         Status: Rejected

Impossible to connect digital camera acting as USB mass storage to
Ubuntu 5.10

I have HP PhotoSmart M307 digital camera which is configured to connect
to computer as USB disk drive. This works perfectly with SuSE 9.3 and

After I installed Ubuntu 5.10 over FC3 on the same machine, I haven't
been able to connect the camera to the computer anymore. It still works
with my other computer running SuSE 9.3. I'm not able to mount the USB
drive automaticly nor manually through mount command. When camera is
connected, "sudo fdisk -l" hangs.

I'm not sure this is bug of hal, but since I'm not able to mount the USB
storage even manually, it shouldn't be problem of gvm. I noticed that
there are similar bug reports, but in those cases manual mount has
worked or installing libpmount0.0 or some other package has fixed the
problem. I've tried those fixes and work arounds with no luck.

Output of uname -a

Linux metical 2.6.12-10-386 #1 Mon Feb 13 12:13:15 UTC 2006 i686

Output of id:

uid=1000(hannele) gid=1000(hannele)

output of id hal:

uid=111(hal) gid=111(hal)

Mounting of USB storage fails

More information about the kernel-bugs mailing list