[Bug 26021] iBook g4 unable to sleep

Scott Henson scotth at csee.wvu.edu
Thu Mar 9 12:00:38 UTC 2006

Public bug reported:

Affects: linux-source-2.6.15 (Ubuntu)
       Severity: Normal
       Priority: Medium
       Assignee: Ubuntu Kernel Team
         Status: In Progress

I have an iBook g4 with a 800MHz cpu and a Radeon M9 9200 Mobility.

This is on a fresh breezy install updated as of today.

The problem comes down to the fact that I cannot get my ibook to sleep.  It
slept under hoary with the same setup, but now with breezy, it claims that it is
unable to sleep.  Additionally, I can't get the backlight to change in
brightness.  This too worked under hoary.  The weird thing about it is that I
upgraded the working hoary setup to breezy, and I still had working sleep and
backlight.  I wiped the system and installed fresh breezy, and no sleep or
backlight.  So I'm convinced the problem is with some config file that was there
with hoary and survived to breezy, but is not there under the fresh breezy install.

pbbcmd sleep does absolutely nothing.  When I query pbbcmd to see if sleep is
available, it says it is not.

Looking at bug 17570 [https://launchpad.net/malone/bugtrackers/ubuntu-bugzilla/17570], it has a command( echo mem | sudo tee /sys/power/state)
that puts my laptop to sleep for a second and then it wakes back up.  dmesg says
the following.
[  746.422371] Stopping tasks:
[  746.424934] pmac_pm_prepare(3)
[  746.921174] eth0: suspending, WakeOnLan disabled
[  747.319240] pmac_pm_enter(3)
[  747.400098] PCI: Enabling device 0001:10:1b.0 (0000 -> 0002)
[  747.461099] PCI: Enabling device 0001:10:1b.1 (0000 -> 0002)
[  747.522100] PCI: Enabling device 0001:10:1b.2 (0000 -> 0002)
[  747.543101] ehci_hcd 0001:10:1b.2: park 0
[  747.543236] ehci_hcd 0001:10:1b.2: USB 2.0 restarted, EHCI 1.00, driver 10
Dec 2004
[  748.576106] eth0: resuming
[  748.638416] PHY ID: 4061e4, addr: 0
[  751.038182] eth0: Link is up at 100 Mbps, full-duplex.
[  751.038368] eth0: Pause is disabled
[  751.073702] hda: Enabling Ultra DMA 5
[  751.076896] hdc: Enabling MultiWord DMA 2
[  751.078078] pmac_pm_finish(3)
[  751.078176] Restarting tasks... done
[  751.143356] agpgart: Putting AGP V2 device at 0000:00:0b.0 into 1x mode
[  751.143379] agpgart: Putting AGP V2 device at 0000:00:10.0 into 1x mode
[  751.143444] [drm] Loading R200 Microcode

The difference between that bug and this one is that sleep should work on
radeons.  Also bug 1940 [https://launchpad.net/malone/bugtrackers/ubuntu-bugzilla/1940] is related, but that bug is about waking up, I can't
even get to sleep.  

I really concider this to be a major regression wrt hoary.  Its also a pretty
major bug because it makes my ibook almost useless under Ubuntu(I move around a
lot and having my laptop sleep is very much needed).

Thanks, I tried tracking down the bug myself inside of pbbuttonsd, but it came
down to the kernel telling it that it couldn't sleep, but I know this kernel
sleeps as it did in the upgraded system.  Additionally I tried the hoary kernel
with no sucess.  I don't think that this is really a bug with pbbuttonsd, but
that is a good starting place.  Thanks again.

More information about the kernel-bugs mailing list