[Bug 52394] Re: T42 fails to resume from suspend on Dapper

Fred Benenson fcb at fredbenenson.com
Sun Jul 9 03:07:52 UTC 2006


** Summary changed:

- T42 fails to resume from suspend 
+ T42 fails to resume from suspend on Dapper

** Description changed:

  Binary package hint: linux-686
  
- I've modified /boot/grub/menu.lst to include apm=on acpi=off nolapic
- acpi_sleep=s3_bios resume=/dev/hda2 on boot, and set ACPI_SLEEP=true in
- /etc/default/acpi-support. I can get the machine to go into Sleep mode,
- but when I hit Fn to get it out, and it starts resuming, it freezes just
- as it begins to render the screen. Most of the time a little box of
- horizontal lines appears over where my cursor left off, but one time I
- was able to get it to draw most of my desktop, though the image was
- totally garbled and the machine was essentially unresponsive.
+ Running Dapper Drake, upgraded from Breezy (where sleep worked like a
+ charm).
+ 
+ Anyway, I've modified /boot/grub/menu.lst to include apm=on acpi=off
+ nolapic acpi_sleep=s3_bios resume=/dev/hda2 on boot, and set
+ ACPI_SLEEP=true in /etc/default/acpi-support. I can get the machine to
+ go into Sleep mode, but when I hit Fn to get it out, and it starts
+ resuming, it freezes just as it begins to render the screen. Most of the
+ time a little box of horizontal lines appears over where my cursor left
+ off, but one time I was able to get it to draw most of my desktop,
+ though the image was totally garbled and the machine was essentially
+ unresponsive. I have to hard reboot to fix.
  
  I'm using the fglrx drivers for X, but the ati ones didn't seem to solve
  this problem either.
  
  Any thoughts? Or places to look for what precise error is ocurring on
  resume?
  
  Thanks.
  
  F

-- 
T42 fails to resume from suspend on Dapper
https://launchpad.net/bugs/52394




More information about the kernel-bugs mailing list