[Bug 46510] Re: At boot doesn't recognize aic9405 controller sas/sata

Iván Campaña ivan.campana at gmail.com
Mon Dec 4 09:02:20 UTC 2006


I just installed edgy on a IBM xseries 206m, had the same problem, after
installing it couldn't boot because it was not able to load the drivers.

I wasted almost a 2 days reading different ways to solve it from debian
tutorials, none of those worked.  The real solution took less than 15
minutes and would have save me from quite a headache.

Probably someone with experience read this bug description and
understood the way to solve it, but since I read this over and over and
could find an exit, here is the way to solve the problem:

After installing edgy or dapper from the live cd, don't reboot.  Keep working with the live CD.  Open a terminal and create a directory to mount the just installed system and chroot to that directory example:
#sudo -s
#mkdir /media/linux_206m
#mount /dev/sda1 /media/linux_206m
#chroot /media/linux_206m

(Assuming that sda1 is the partition where ubuntu is installed.)

Once you get there just edit this file: /etc/initramfs-tools/modules
Add a new line at the end of the file and write aic94xx
Close the file and execute this command:
        update-initramfs -u -k all

Wait till it finish and problem solved, remove the live cd, reboot and
it should recognize the adaptec card and boot normally, no need to
modify the kernel, recompile, download anything or use extra tools.

Hope it helps someone.

-- 
At boot doesn't recognize aic9405 controller sas/sata
https://launchpad.net/bugs/46510




More information about the kernel-bugs mailing list