[Bug 36512] Dell Inspiron 630m sound is broken

William Grant tanarrifujitsu at optusnet.com.au
Thu Apr 6 01:20:51 UTC 2006


Public bug reported:

Affects: linux-source-2.6.15 (Ubuntu)
       Severity: Normal
       Priority: Low
     Assignee: Ben Collins
         Status: In Progress


Description:
The Dell Inspiron 630m's sound is broken. All it can do is play sounds
through the speakers.

Applications attempting to use the microphone hang, and alsamixer is
very bare (basically just Master and PCM sliders, with a disfunctional
Microphone one). This is probably because the Intel HDA Audio in the
laptop uses the Sigmatel STAC9750, which is not entirely supported by
ALSA, it would appear.

Here are details of the device, as returned by lspci -vv:

0000:00:1b.0 0403: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
        Subsystem: Dell: Unknown device 01b5
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0, Cache Line Size: 0x10 (64 bytes)
        Interrupt: pin A routed to IRQ 169
        Region 0: Memory at dfebc000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [60] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
                Address: 0000000000000000  Data: 0000
        Capabilities: [70] #10 [0091]
Public bug reported:

Affects: linux-source-2.6.15 (Ubuntu)
       Severity: Normal
       Priority: Low
     Assignee: Ben Collins
         Status: In Progress


Description:
The Dell Inspiron 630m's sound is broken. All it can do is play sounds
through the speakers.

Applications attempting to use the microphone hang, and alsamixer is
very bare (basically just Master and PCM sliders, with a disfunctional
Microphone one). This is probably because the Intel HDA Audio in the
laptop uses the Sigmatel STAC9750, which is not entirely supported by
ALSA, it would appear.

Here are details of the device, as returned by lspci -vv:

0000:00:1b.0 0403: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
        Subsystem: Dell: Unknown device 01b5
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0, Cache Line Size: 0x10 (64 bytes)
        Interrupt: pin A routed to IRQ 169
        Region 0: Memory at dfebc000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [60] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
                Address: 0000000000000000  Data: 0000
        Capabilities: [70] #10 [0091]
-- 
Dell Inspiron 630m sound is broken
https://launchpad.net/malone/bugs/36512




More information about the kernel-bugs mailing list