[Bug 14995] New: Live CD HP dx5150 MT (Athlon64) does not boot with USB DVD drive attached

bugzilla-daemon at bugzilla.ubuntu.com bugzilla-daemon at bugzilla.ubuntu.com
Thu Sep 8 22:59:33 UTC 2005


Please do not reply to this email.  You can add comments at
http://bugzilla.ubuntu.com/show_bug.cgi?id=14995
Ubuntu | linux

           Summary: Live CD HP dx5150 MT (Athlon64) does not boot with USB
                    DVD drive attached
           Product: Ubuntu
           Version: unspecified
          Platform: amd64
        OS/Version: other
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: linux
        AssignedTo: ben.collins at ubuntu.com
        ReportedBy: joe at k12s.phast.umass.edu
         QAContact: kernel-bugs at lists.ubuntu.com


I have an HP DX5150 MT (Athlon64) machine on my desk at work, and am currently
running hoary with a custom compiled kernel, and custom compiled x.org to get
things *mostly* working.  I'm hoping breezy will work out of the box.  I'll be
writing up many bugs w/ this machine (it has all REALLY new hardware new to 2.6.12).

Trying to boot the Breezy AMD64 live-CD 9/6 build, if I have my USB DVD+-RW
drive attached to the system, it freezes during bootup.  (I am *NOT* booting
from this drive, it just happens to be attached).  Unfortunately it crashes
early enough I don't get alot of useful debug. It crashes with this on the screen:

ACPI: bus type ide registered
 atiixp: loaded successfully
ohci_hcd 0000:00:13.0: Unlink after no-IRQ?  Controller is probably using the
wrong IRQ.
  PCI  [success]
Running /etc/hotplug/usb.rc

On my current hoary system (with custom kernel+crazyness) the drive works, and
the system boots.  When I plug in the drive, my system puts this into the syslog:

Sep  8 18:55:29 artemis kernel: [37413.497265] usb 3-2: new high speed USB
device using ehci_hcd and address 3
Sep  8 18:55:29 artemis kernel: [37413.737387] Initializing USB Mass Storage
driver...
Sep  8 18:55:29 artemis kernel: [37413.745711] scsi2 : SCSI emulation for USB
Mass Storage devices
Sep  8 18:55:29 artemis kernel: [37413.746204] usb-storage: device found at 3
Sep  8 18:55:29 artemis kernel: [37413.746206] usb-storage: waiting for device
to settle before scanning
Sep  8 18:55:29 artemis kernel: [37413.746305] usbcore: registered new driver
usb-storage
Sep  8 18:55:29 artemis kernel: [37413.746307] USB Mass Storage support registered.
Sep  8 18:55:29 artemis usb.agent[24335]:      usb-storage: loaded successfully
Sep  8 18:55:34 artemis kernel: [37416.016359]   Vendor: HL-DT-ST  Model: DVDRAM
GSA-4081B  Rev: A100
Sep  8 18:55:34 artemis kernel: [37416.016367]   Type:   CD-ROM                
            ANSI SCSI revision: 00
Sep  8 18:55:34 artemis kernel: [37416.019756] usb-storage: device scan complete
Sep  8 18:55:34 artemis kernel: [37416.100054] sr0: scsi3-mmc drive: 62x/62x
writer dvd-ram cd/rw xa/form2 cdda tray
Sep  8 18:55:34 artemis kernel: [37416.100538] Attached scsi CD-ROM sr0 at
scsi2, channel 0, id 0, lun 0
Sep  8 18:55:34 artemis scsi.agent[24412]:      sr_mod: loaded sucessfully
Sep  8 18:55:34 artemis udev[24449]: creating device node '/dev/sg0'
Sep  8 18:55:34 artemis kernel: [37416.115385] Attached scsi generic sg0 at
scsi1, channel 0, id 0, lun 0,  type 0
Sep  8 18:55:34 artemis kernel: [37416.115831] Attached scsi generic sg1 at
scsi2, channel 0, id 0, lun 0,  type 5
Sep  8 18:55:34 artemis scsi.agent[24412]:      sg: loaded sucessfully
Sep  8 18:55:34 artemis udev[24464]: configured rule in
'/etc/udev/rules.d/udev.rules' at line 24 applied, 'sg1' becomes '%k'
Sep  8 18:55:34 artemis udev[24464]: creating device node '/dev/sg1'
Sep  8 18:55:35 artemis udev[24462]: configured rule in
'/etc/udev/rules.d/cd-aliases.rules' at line 8 applied, added symlink '%c{1}
%c{2} %c{3} %c{4} %c{5} %c{6}'
Sep  8 18:55:35 artemis udev[24462]: configured rule in
'/etc/udev/rules.d/udev.rules' at line 23 applied, added symlink 'sr%n'
Sep  8 18:55:35 artemis udev[24462]: configured rule in
'/etc/udev/rules.d/udev.rules' at line 23 applied, 'sr0' becomes 'scd%n'
Sep  8 18:55:35 artemis udev[24462]: creating device node '/dev/scd0'
Sep  8 18:55:35 artemis kernel: [37416.307786] cdrom: This disc doesn't have any
tracks I recognize!

I will attach my /proc/bus/usb/devices file from my hoary setup to this bug.

If I remove the drive, the system will boot past this point (but still doesn't
boot because of other issues described in other bugs)

-- 
Configure bugmail: http://bugzilla.ubuntu.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.




More information about the kernel-bugs mailing list