[Bug 21723] New: /dev/pmu missing after upgrade to dapper

bugzilla-daemon at bugzilla.ubuntu.com bugzilla-daemon at bugzilla.ubuntu.com
Sat Dec 31 19:04:28 UTC 2005


Please do not reply to this email.  You can add comments at
http://bugzilla.ubuntu.com/show_bug.cgi?id=21723
Ubuntu | linux

           Summary: /dev/pmu missing after upgrade to dapper
           Product: Ubuntu
           Version: unspecified
          Platform: powerpc
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: linux
        AssignedTo: ben.collins at ubuntu.com
        ReportedBy: giles at xiph.org
         QAContact: kernel-bugs at lists.ubuntu.com


I upgraded my rev A 400 MHz Powerbook G4 from current Breezy to Dapper last
night. Most things worked, but the machine no longer goes to sleep.

I don't know much about the event chain, but based on some of the other open
sleep bugs, I tried 'pbbcmd sleep', which complained "ERROR: Problems with IPC,
mayber server is not running." Indeed, pbbuttonsd isn't running.
'/etc/init.d/pbbuttonsd start' says "ERROR: The file '/dev/pmu' doesn't exist."
And indeed it does not.

This seems like a bug in the udev stuff, but it might also just be a package
archive problem. I'd expected the kernel to upgrade, but the machine is still
running 2.6.12-10-powerpc. 'apt-get install linux-image-powerpc' complains:

  linux-image-powerpc: Depends: linux-image-2.6.15-10-powerpc but it is not
installable
  E: Broken packages

So, while it might be version skew, it does seem like the system ought to be
able to cope on top of the old kernel.

I'm happy to help debug if you need more information.

-- 
Configure bugmail: http://bugzilla.ubuntu.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.




More information about the kernel-bugs mailing list