[Bug 21500] kernel-package: latest unstable version breaks linux-2.6 build on amd64

bugzilla-daemon at bugzilla.ubuntu.com bugzilla-daemon at bugzilla.ubuntu.com
Sun Dec 25 17:32:46 UTC 2005


Please do not reply to this email.  You can add comments at
http://bugzilla.ubuntu.com/show_bug.cgi?id=21500
Ubuntu | kernel-package





------- Additional Comments From debzilla at ubuntu.com  2005-12-25 17:32 UTC -------
Message-Id: <E1EqZ1W-0008Uk-Jq at spohr.debian.org>
Date: Sun, 25 Dec 2005 08:47:06 -0800
From: Manoj Srivastava <srivasta at debian.org>
To: 344740-close at bugs.debian.org
Subject: Bug#344740: fixed in kernel-package 10.025

Source: kernel-package
Source-Version: 10.025

We believe that the bug you reported is fixed in the latest version of
kernel-package, which is due to be installed in the Debian FTP archive:

kernel-package_10.025.dsc
  to pool/main/k/kernel-package/kernel-package_10.025.dsc
kernel-package_10.025.tar.gz
  to pool/main/k/kernel-package/kernel-package_10.025.tar.gz
kernel-package_10.025_all.deb
  to pool/main/k/kernel-package/kernel-package_10.025_all.deb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 344740 at bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Manoj Srivastava <srivasta at debian.org> (supplier of updated kernel-package package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster at debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Sun, 25 Dec 2005 10:14:33 -0600
Source: kernel-package
Binary: kernel-package
Architecture: source all
Version: 10.025
Distribution: unstable
Urgency: low
Maintainer: Manoj Srivastava <srivasta at debian.org>
Changed-By: Manoj Srivastava <srivasta at debian.org>
Description: 
 kernel-package - A utility for building Linux kernel related Debian packages.
Closes: 344413 344740
Changes: 
 kernel-package (10.025) unstable; urgency=low
 .
   * Bug fix: "kernel-package: latest unstable version breaks linux-2.6
     build on amd64", thanks to Frederik Schueler. Now we let the
     architecture still be whatever DEB_HOST_ARCH_CPU says it should
     be. Just set KERNEL_ARCH correctly on amd64/x86_64 machines early, so
     that make-kpkg clean does not flake out when there is no ./debian dir.
     Accept either x86_64 or amd64 as the architecture, just in case, when
     selecting the correct Makefile snippet. So it is perfectly fine to
     still say --arch=amd64, like  linux-2.6 does             (Closes: #344740).
   * Bug fix: "[powerpc] k-p 10.00x breaks debconf based /etc/kernel/*.d
     scripts like mkvmlinuz", thanks to Sven Luther. Well. In the recent
     10.X series, kernel package has started producing image packages whose
     maintainer scripts use debconf for user interaction. Unfortunately,
     this meant that any hook scripts called in the maintainer scripts for
     the image package (update-grub comes to mind), if they wrote anything
     at all to the STDOUT, would cause debconf to throw hissy fits, since
     it was expecting commands on STDOUT, not random chatter from the hook
     scripts.
 .
     One solution was to call db_stop before calling the hook scripts, and
     redirecting stdout to stderr in hte invocation of the
     scripts. Unfortunately, this made any scripts that used debconf
     impossible.
 .
     So, either we ban scripts that are interactive, or scripts that
     scribble on stdout.  Since the former makes some functionality
     impossible (some scripts can delicer added functionality and
     flexibility of they can interact with users), and the latter just
     needs a code change, I would prefer to ask packages that provide
     scripts to be used in kernel image postinst/postrm to use debconf for
     user interaction, and to send diagnostics to STDERR
                                                               (Closes: #344413).
Files: 
 220e7eb75eca8a0f477a2b7f695ce245 485 misc optional kernel-package_10.025.dsc
 e916f36b6106cd3ca3aa9d19a3e7c7c1 764014 misc optional kernel-package_10.025.tar.gz
 b2a5bf89052b09890dac726e12abb69b 517940 misc optional kernel-package_10.025_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFDrsmjIbrau78kQkwRAoFOAJwJi7p7eewaKTcpyA4ke4pW1bq2tQCgr6qy
XAZmQBZbKjfyfJ8c5WD9jMo=
=0pbZ
-----END PGP SIGNATURE-----





-- 
Configure bugmail: http://bugzilla.ubuntu.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.




More information about the kernel-bugs mailing list