[Bug 20772] New: No sound with intel8x0 after upgrading to 2.6.12-9-686

bugzilla-daemon at bugzilla.ubuntu.com bugzilla-daemon at bugzilla.ubuntu.com
Fri Dec 9 18:32:46 UTC 2005

Please do not reply to this email.  You can add comments at
Ubuntu | kernel-package

           Summary: No sound with intel8x0 after upgrading to 2.6.12-9-686
           Product: Ubuntu
           Version: unspecified
          Platform: i386
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: kernel-package
        AssignedTo: ben.collins at ubuntu.com
        ReportedBy: karltk at gentoo.org
         QAContact: kernel-bugs at lists.ubuntu.com

After upgrading my kernel from 2.6.10-5-686 to 2.6.12-9-686, the likelihood of
hearing any sound after booting the machine has gone from 100% to about ~0%.
Apparently, the snd_intel8x0 driver in 2.6.12-9-686 has problems either
initializing the sound card, setting the volume correctly, or feeding it data.

My hardware is an IBM x31 laptop, with an AC'97 Audio Controller:

0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
        Subsystem: IBM: Unknown device 0534

The problem manifests itself as follows:

1) I can boot 2.6.10-5-686 into text mode (no X11 running at all), and play
sound using mpg123 -o alsa (or even oss)
   just fine. I sometimes need to adjust the PCM and Master volume using
alsamixer, if my previous boot was into

2) When booting 2.6.12-10-686 (still not starting X11), I cannot get any sound
at all, even after adjusting the volume
   using alsamixer. Once in a blue moon, suspending the machine and resuming it
may bring the sound about, but this is
   not reliable.

(The matter does not change by starting X11; artsd does not magically make the
sound work)

I notice that the alsactl restore command which runs during startup to reset the
volume settings complains about unknown channels when I switch between the
kernels. That is, after first booting into 2.6.12-10-686, adjusting the volumes
alsamixer (but not getting any sound), then rebooting into 2.6.10-5-686, I get:

alsactl: set_control:894: warning: name mismatch (Headphone Jack Sense/External
Amplifier) for control #26
alsactl: set_control:896: warning: index mismatch (0/0) for control #26
alsactl: set_control:873: failed to obtain info for control #27 (No such file or

My guess is that the control numbers for the Master and PCM channels have
changed between the two kernel versions. For
2.6.12-10-686, both alsamixer (and kmix) think they are adjusting the Master and
PCM volumes, while the are in fact adjusting some other channels of the sound card.

I have played with all the volume controls (and the mute setting), but none of
them will bring about sound in 2.6.12-10-686.

I have not tried other 2.6.12-x-686 versions, so I cannot point out where the
regression occurred.

Please advise.

Configure bugmail: http://bugzilla.ubuntu.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.

More information about the kernel-bugs mailing list