[ubuntu/karmic] brltty 4.0-6ubuntu1 (Accepted)

Luke Yelavich themuso at ubuntu.com
Thu May 28 09:20:13 BST 2009


brltty (4.0-6ubuntu1) karmic; urgency=low

  * Merge from debian unstable, remaining changes:
    - Conflicts: libbrlapi, libbrlapi-dev, libbrlapi1-dev.
    - Add brltty-setup, installed in both the udeb and the normal system.
    - Add initramfs integration to run brltty-setup if necessary before
      usplash starts.
    - Add ubiquity integration to propagate any brltty configuration to the
      target system.
    - Add udev rules and /lib/brltty/brltty.sh to the normal (non-udeb)
      package as well.
    - Enable brltty if /etc/default/brltty has RUN_BRLTTY=yes, which is set
      by the installer if brltty is configured; add a NEWS entry for
      upgraders.
    - Install udev rules with the same name (85-brltty.rules) in the udeb as
      in the deb.
    - Only copy the brltty config file from the initramfs if the md5sum differs.
    - Change maintainer to Ubuntu Accessibility Developers
      <ubuntu-accessibility-devel at lists.ubuntu.com>
    - Disable BrlTTY grabbing devices that use the FTDI USB to serial chip.
    - Remove the dh-lisp build-dependency, remove the cl-brlapi package, and
      adjust the brltty package description accordingly. dh-lisp is not
      in main.
    - Do not build the speechd package, speech-dispatcher is not in main.
    - Build for python 2.6.
    - Build against openjdk in Ubuntu.
    - Put udev rules file in /lib/udev/rules.d.
    - Enable brltty at startup on the target system if the alternate installer
      is used.

brltty (4.0-6) unstable; urgency=low

  [ Mario Lang ]
  * debian/control:
    - Remove libbluetooth2-dev from Build-Depends. (Closes: 530355)
    - Add Vcs-Git and Vcs-Browser fields.

  [ Samuel Thibault ]
  * Add Homepage field.

  [ Mario Lang ]
  * debian/control:
    - Set Maintainer to "Debian Accessibility Team".
    - Update package description to mention newly supported displays.
  * Fix from upstream SVN:
    r4495: The Java bindings should load the JNI part automatically.

brltty (4.0-5) unstable; urgency=low

  * Fix "X11 is left enabled" by changing --without-x to --disable-x
    during udeb configure (Closes: #529526)

brltty (4.0-4) unstable; urgency=low

  * debian/brltty-udeb.udev.rules: Add new USB IDs.
  * debian/brltty.docs: Install Tables/README-* which
    fixes "Should provide the tables documentation". (Closes: #522702)
  * debian/brltty.examples: Install Hotplug/udev.rules and
    Hotplug/upstart.job.
  * debian/libbrlapi0.5.copyright: Update copyright years and mention
    LGPL version.

brltty (4.0-3) unstable; urgency=low

  * Fix Build-Depends to actually include libspeechd-dev.
    A comma was missing, argh!

brltty (4.0-2) unstable; urgency=low

  * debian/control: Move cl-brlapi from section admin to lisp.
  * Enable speech-dispatcher support via new binary package
    brltty-speechd. (Closes: #486291)
  * Update debian/copyright:
    - Update copyright years.
    - Mention /usr/share/doc/brltty/CONTRIBUTORS.
    - Add info about license version.
    - Mention that tables are now licensed LGPL.
  * debian/brltty.docs: Install Documents/CONTRIBUTORS.
  * Merge from Ubuntu: "Add 'status' action to init script":
    - debian/control: brltty: Depend on lsb-base >= 3.2-14, providing
      status_of_proc().
    - debian/brltty.init: Add the 'status' action.

brltty (4.0-1) unstable; urgency=low

  * New upstream release:
    - Fixes "causes excessive resume of USB" (Closes: #497155).
  * Fix "Bus specifiers are mistakenly interpreted as relative paths"
    by removing not so clever code from debian/brltty-udeb.prebaseconfig
    (Closes: #516091)
  * Fix "Use libncursew5-dev". (Closes: #488993)
  * debian/control: Move libbrlapi-java from section libs to java.
  * Upgrade Standards-Version from 3.7.3 to 3.8.1 (no changes).
  * debian/brltty.examples: Remove, unused.

Date: Thu, 28 May 2009 09:56:12 +0200
Changed-By: Luke Yelavich <themuso at ubuntu.com>
Maintainer: Ubuntu Accessibility Developers <ubuntu-accessibility-devel at lists.ubuntu.com>
Signed-By: Luke Yelavich <luke.yelavich at canonical.com>
https://launchpad.net/ubuntu/karmic/+source/brltty/4.0-6ubuntu1
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Thu, 28 May 2009 09:56:12 +0200
Source: brltty
Binary: brltty libbrlapi0.5 libbrlapi-dev libbrlapi-jni libbrlapi-java brltty-flite brltty-udeb brltty-x11 python-brlapi
Architecture: source
Version: 4.0-6ubuntu1
Distribution: karmic
Urgency: low
Maintainer: Ubuntu Accessibility Developers <ubuntu-accessibility-devel at lists.ubuntu.com>
Changed-By: Luke Yelavich <themuso at ubuntu.com>
Description: 
 brltty     - Access software for a blind person using a braille display
 brltty-flite - Access software for a blind person using a braille display
 brltty-udeb - Access software for a blind person using a braille display (udeb)
 brltty-x11 - Access software for a blind person using a braille display
 libbrlapi-dev - Library for communication with BRLTTY - static libs and headers
 libbrlapi-java - Java bindings for BrlAPI
 libbrlapi-jni - Java bindings for BrlAPI (native library)
 libbrlapi0.5 - braille display access via BRLTTY - shared library
 python-brlapi - Python bindings for BrlAPI
Closes: 486291 488993 497155 516091 522702 529526 530355
Changes: 
 brltty (4.0-6ubuntu1) karmic; urgency=low
 .
   * Merge from debian unstable, remaining changes:
     - Conflicts: libbrlapi, libbrlapi-dev, libbrlapi1-dev.
     - Add brltty-setup, installed in both the udeb and the normal system.
     - Add initramfs integration to run brltty-setup if necessary before
       usplash starts.
     - Add ubiquity integration to propagate any brltty configuration to the
       target system.
     - Add udev rules and /lib/brltty/brltty.sh to the normal (non-udeb)
       package as well.
     - Enable brltty if /etc/default/brltty has RUN_BRLTTY=yes, which is set
       by the installer if brltty is configured; add a NEWS entry for
       upgraders.
     - Install udev rules with the same name (85-brltty.rules) in the udeb as
       in the deb.
     - Only copy the brltty config file from the initramfs if the md5sum differs.
     - Change maintainer to Ubuntu Accessibility Developers
       <ubuntu-accessibility-devel at lists.ubuntu.com>
     - Disable BrlTTY grabbing devices that use the FTDI USB to serial chip.
     - Remove the dh-lisp build-dependency, remove the cl-brlapi package, and
       adjust the brltty package description accordingly. dh-lisp is not
       in main.
     - Do not build the speechd package, speech-dispatcher is not in main.
     - Build for python 2.6.
     - Build against openjdk in Ubuntu.
     - Put udev rules file in /lib/udev/rules.d.
     - Enable brltty at startup on the target system if the alternate installer
       is used.
 .
 brltty (4.0-6) unstable; urgency=low
 .
   [ Mario Lang ]
   * debian/control:
     - Remove libbluetooth2-dev from Build-Depends. (Closes: 530355)
     - Add Vcs-Git and Vcs-Browser fields.
 .
   [ Samuel Thibault ]
   * Add Homepage field.
 .
   [ Mario Lang ]
   * debian/control:
     - Set Maintainer to "Debian Accessibility Team".
     - Update package description to mention newly supported displays.
   * Fix from upstream SVN:
     r4495: The Java bindings should load the JNI part automatically.
 .
 brltty (4.0-5) unstable; urgency=low
 .
   * Fix "X11 is left enabled" by changing --without-x to --disable-x
     during udeb configure (Closes: #529526)
 .
 brltty (4.0-4) unstable; urgency=low
 .
   * debian/brltty-udeb.udev.rules: Add new USB IDs.
   * debian/brltty.docs: Install Tables/README-* which
     fixes "Should provide the tables documentation". (Closes: #522702)
   * debian/brltty.examples: Install Hotplug/udev.rules and
     Hotplug/upstart.job.
   * debian/libbrlapi0.5.copyright: Update copyright years and mention
     LGPL version.
 .
 brltty (4.0-3) unstable; urgency=low
 .
   * Fix Build-Depends to actually include libspeechd-dev.
     A comma was missing, argh!
 .
 brltty (4.0-2) unstable; urgency=low
 .
   * debian/control: Move cl-brlapi from section admin to lisp.
   * Enable speech-dispatcher support via new binary package
     brltty-speechd. (Closes: #486291)
   * Update debian/copyright:
     - Update copyright years.
     - Mention /usr/share/doc/brltty/CONTRIBUTORS.
     - Add info about license version.
     - Mention that tables are now licensed LGPL.
   * debian/brltty.docs: Install Documents/CONTRIBUTORS.
   * Merge from Ubuntu: "Add 'status' action to init script":
     - debian/control: brltty: Depend on lsb-base >= 3.2-14, providing
       status_of_proc().
     - debian/brltty.init: Add the 'status' action.
 .
 brltty (4.0-1) unstable; urgency=low
 .
   * New upstream release:
     - Fixes "causes excessive resume of USB" (Closes: #497155).
   * Fix "Bus specifiers are mistakenly interpreted as relative paths"
     by removing not so clever code from debian/brltty-udeb.prebaseconfig
     (Closes: #516091)
   * Fix "Use libncursew5-dev". (Closes: #488993)
   * debian/control: Move libbrlapi-java from section libs to java.
   * Upgrade Standards-Version from 3.7.3 to 3.8.1 (no changes).
   * debian/brltty.examples: Remove, unused.
Checksums-Sha1: 
 98ccd78e097ed7b0d779e2d042b44d9f3cbb1b2c 1733 brltty_4.0-6ubuntu1.dsc
 a966e0818bf2cc6927c7bd1e3ae52f9bbf13b031 2135287 brltty_4.0.orig.tar.gz
 bddaefc21a64e54d943820ccf83ceba6dcb9a861 23824 brltty_4.0-6ubuntu1.diff.gz
Checksums-Sha256: 
 c8833643bb0300bb47e43017a34c75997bc4652dcb669763ac2e5c879954b56b 1733 brltty_4.0-6ubuntu1.dsc
 961ce89057600852674dc199f18d135261f27442e7ff69c767a12a9e07ca01ce 2135287 brltty_4.0.orig.tar.gz
 66fcb504d9b3fb86de1f0627fc100bf85629d53e892125beb0056c9319f63192 23824 brltty_4.0-6ubuntu1.diff.gz
Files: 
 5408f6a949aa07a63e6dd94d335b0787 1733 admin extra brltty_4.0-6ubuntu1.dsc
 2862727384a1308dbff3031efb85c41e 2135287 admin extra brltty_4.0.orig.tar.gz
 c9408d4919b1b301ceeb9d88800153ef 23824 admin extra brltty_4.0-6ubuntu1.diff.gz
Original-Maintainer: Debian Accessibility Team <debian-accessibility at lists.debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkoeRRMACgkQjVefwtBjIM5K7QCeMmiCAxgdx2Ie3iiXa9MOeT9F
KE8AoI7dpW+APVF7Acpi/05j4CPbTYzB
=VPPl
-----END PGP SIGNATURE-----


More information about the Karmic-changes mailing list