[ubuntu/karmic] python-qt4 4.4.4-6ubuntu1 (Accepted)

Scott Kitterman scott at kitterman.com
Fri May 22 00:00:16 BST 2009


python-qt4 (4.4.4-6ubuntu1) karmic; urgency=low

  * Merge from debian unstable, remaining changes:
    - Build-depend on libqt4-phonon-dev instead of libphonon-dev because
      Kubuntu is using Phonon from Qt instead of KDE now

python-qt4 (4.4.4-6) unstable; urgency=medium

  * medium urgency as we are fixing a RC bug which makes
    several other packages FTBFS.
  * debian/rules:
    - Prepare build-process for Python 2.6.
    - Install the python-qt4-dbus debug extensions properly again,
      they were forgotten during the migration to python-support.
    - Move pyuic4's widget-plugins directory to
      /usr/share/python-qt4 as the directory must not be a
      namespace package - therefore it doesn't make sense to install
      it within the normal modules directory.
      Thanks to Pierre Chifflier for the bugreport (Closes: #523059).
  * debian/*.install:
    - Handle *-package directories to support Python 2.6.
  * debian/control:
    - Use versioned dependencies on python-qt4-common,
      thanks to Zed Pobre for the bug report (Closes: #505572).
    - pyqt4-dev-tools: make the dependency on python-qt a
      versioned one.
  * debian/patches/04_widget-plugins_location.dpatch:
    - Adding patch to tell pyuic about the new location of the
      widget plugins.

python-qt4 (4.4.4-5) unstable; urgency=low

  * debian/control:
    - Switch to python-support, drop all X*-Python fields.
    - Adding myeslf to Uploaders.
  * debian/rules:
    - Avoid all insane hacks which were messing with
      /var/lib/python-support. This was prone to fail in any case,
      and will result in FTBFS as soon as python-support 1.0 will
      hit unstable. This should also fix #512739 as python-support
      uses triggers, so the broken 'local' file (which was installed
      via python-central from an old package) will be gone.
      (Closes: #512739)
    - Create debian/python-qt4-dbus.install on the fly as
      directories may change depending on the used python-support
      version.
  * debian/README.source, debian/pycompat:
    - Dropping file, not needed anymore.
  * debian/python-qt4-dbus.install: dropping file, see above.
  * debian/pyversions: create file, build for Python 2.4 and later.

python-qt4 (4.4.4-4) unstable; urgency=low

  [ Sandro Tosi ]
  * debian/manpages/pyuic4.1
    - fixed minor error; thanks to Ori Avtalion for the report; Closes: #518957

  [ Michael Casadevall ]
  * Moved package from experimental to unstable
  * debian/control:
    - Updated my email to mcasadevall at debian.org
    - Bumped standards version to 3.8.1
    - Corrected section mismatches
      - Changed python-qt-*-dbg section to debug
    - Tightened build-deps to match normal dependences.
      - sip4 versioned to build against 4.7.9 matching the Depends

python-qt4 (4.4.4-3) experimental; urgency=low

  [ Torsten Marek ]
  * debian/control
    - increase python-sip4 dependecy to 4.7.9, needed by python-qt4-phonon

  [ Michael Casadevall ]
  * Merge of patches from Ubuntu to correct ARM support (LP: #308814)
    - Added debian/patches/03_qreal_float_support.dpatch
      - Corrects a configuration test which caused qreals to end up
        as floats on non-ARM architectures, and as doubles on ARM architectures.
      - Added handling of doubles on qreal != float for QLists
      - Moved pyqtconfig.py from python-qt4-dev to python-qt4
  * debian/rules:
    - Moved pyqtconfig.py installation to python-qt4.install
    - Standardized the uses of spaces and tabs
  * debian/python-qt4.install
    - Install pyqtconfig.py files into python-qt4 vs. python-qt4-dev.
      This is because python-qt4 is arch any, and python-qt4-dev is
      arch all, and the config file can be different on different
      architectures (i.e. ARM)
  * debian/control:
    - Added necessary conflict/replaces to python-qt4
    - Added myself to uploaders

Date: Thu, 21 May 2009 17:12:36 -0400
Changed-By: Scott Kitterman <scott at kitterman.com>
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Signed-By: Scott Kitterman <ubuntu at kitterman.com>
https://launchpad.net/ubuntu/karmic/+source/python-qt4/4.4.4-6ubuntu1
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Thu, 21 May 2009 17:12:36 -0400
Source: python-qt4
Binary: python-qt4 python-qt4-dbg python-qt4-phonon python-qt4-phonon-dbg python-qt4-dbus python-qt4-dbus-dbg python-qt4-gl python-qt4-gl-dbg python-qt4-sql python-qt4-sql-dbg python-qt4-dev python-qt4-common python-qt4-doc pyqt4-dev-tools
Architecture: source
Version: 4.4.4-6ubuntu1
Distribution: karmic
Urgency: medium
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Scott Kitterman <scott at kitterman.com>
Description: 
 pyqt4-dev-tools - Development tools for PyQt4
 python-qt4 - Python bindings for Qt4
 python-qt4-common - Shared files for PyQt4
 python-qt4-dbg - Python bindings for Qt4 (debug extensions)
 python-qt4-dbus - DBus Support for PyQt4
 python-qt4-dbus-dbg - DBus Support for PyQt4 (debug extensions)
 python-qt4-dev - Development files for PyQt4
 python-qt4-doc - Documentation and examples for PyQt4
 python-qt4-gl - Python bindings for Qt4's OpenGL module
 python-qt4-gl-dbg - Python bindings for Qt4's OpenGL module (debug extension)
 python-qt4-phonon - Python bindings for Phonon
 python-qt4-phonon-dbg - Python bindings for Phonon (debug extensions)
 python-qt4-sql - Python bindings for PyQt4's SQL module
 python-qt4-sql-dbg - Python bindings for PyQt4's SQL module (debug extension)
Closes: 505572 512739 518957 523059
Launchpad-Bugs-Fixed: 308814
Changes: 
 python-qt4 (4.4.4-6ubuntu1) karmic; urgency=low
 .
   * Merge from debian unstable, remaining changes:
     - Build-depend on libqt4-phonon-dev instead of libphonon-dev because
       Kubuntu is using Phonon from Qt instead of KDE now
 .
 python-qt4 (4.4.4-6) unstable; urgency=medium
 .
   * medium urgency as we are fixing a RC bug which makes
     several other packages FTBFS.
   * debian/rules:
     - Prepare build-process for Python 2.6.
     - Install the python-qt4-dbus debug extensions properly again,
       they were forgotten during the migration to python-support.
     - Move pyuic4's widget-plugins directory to
       /usr/share/python-qt4 as the directory must not be a
       namespace package - therefore it doesn't make sense to install
       it within the normal modules directory.
       Thanks to Pierre Chifflier for the bugreport (Closes: #523059).
   * debian/*.install:
     - Handle *-package directories to support Python 2.6.
   * debian/control:
     - Use versioned dependencies on python-qt4-common,
       thanks to Zed Pobre for the bug report (Closes: #505572).
     - pyqt4-dev-tools: make the dependency on python-qt a
       versioned one.
   * debian/patches/04_widget-plugins_location.dpatch:
     - Adding patch to tell pyuic about the new location of the
       widget plugins.
 .
 python-qt4 (4.4.4-5) unstable; urgency=low
 .
   * debian/control:
     - Switch to python-support, drop all X*-Python fields.
     - Adding myeslf to Uploaders.
   * debian/rules:
     - Avoid all insane hacks which were messing with
       /var/lib/python-support. This was prone to fail in any case,
       and will result in FTBFS as soon as python-support 1.0 will
       hit unstable. This should also fix #512739 as python-support
       uses triggers, so the broken 'local' file (which was installed
       via python-central from an old package) will be gone.
       (Closes: #512739)
     - Create debian/python-qt4-dbus.install on the fly as
       directories may change depending on the used python-support
       version.
   * debian/README.source, debian/pycompat:
     - Dropping file, not needed anymore.
   * debian/python-qt4-dbus.install: dropping file, see above.
   * debian/pyversions: create file, build for Python 2.4 and later.
 .
 python-qt4 (4.4.4-4) unstable; urgency=low
 .
   [ Sandro Tosi ]
   * debian/manpages/pyuic4.1
     - fixed minor error; thanks to Ori Avtalion for the report; Closes: #518957
 .
   [ Michael Casadevall ]
   * Moved package from experimental to unstable
   * debian/control:
     - Updated my email to mcasadevall at debian.org
     - Bumped standards version to 3.8.1
     - Corrected section mismatches
       - Changed python-qt-*-dbg section to debug
     - Tightened build-deps to match normal dependences.
       - sip4 versioned to build against 4.7.9 matching the Depends
 .
 python-qt4 (4.4.4-3) experimental; urgency=low
 .
   [ Torsten Marek ]
   * debian/control
     - increase python-sip4 dependecy to 4.7.9, needed by python-qt4-phonon
 .
   [ Michael Casadevall ]
   * Merge of patches from Ubuntu to correct ARM support (LP: #308814)
     - Added debian/patches/03_qreal_float_support.dpatch
       - Corrects a configuration test which caused qreals to end up
         as floats on non-ARM architectures, and as doubles on ARM architectures.
       - Added handling of doubles on qreal != float for QLists
       - Moved pyqtconfig.py from python-qt4-dev to python-qt4
   * debian/rules:
     - Moved pyqtconfig.py installation to python-qt4.install
     - Standardized the uses of spaces and tabs
   * debian/python-qt4.install
     - Install pyqtconfig.py files into python-qt4 vs. python-qt4-dev.
       This is because python-qt4 is arch any, and python-qt4-dev is
       arch all, and the config file can be different on different
       architectures (i.e. ARM)
   * debian/control:
     - Added necessary conflict/replaces to python-qt4
     - Added myself to uploaders
Checksums-Sha1: 
 5e3409c22cf21b1ff5efed2d548577c9fdfeca28 2016 python-qt4_4.4.4-6ubuntu1.dsc
 077d264350f56e00a576c6930f25e0d66be4bf37 15780 python-qt4_4.4.4-6ubuntu1.diff.gz
Checksums-Sha256: 
 1514ae9c52c14c8cccc71ffabe0bf866b35470014404e9c110117076f45ef174 2016 python-qt4_4.4.4-6ubuntu1.dsc
 47258121e73535a7d21a5fce53a8db4d75db78af58b16730333f518fd906feba 15780 python-qt4_4.4.4-6ubuntu1.diff.gz
Files: 
 5832f61a25d7cc173b903d4f44b5b409 2016 python optional python-qt4_4.4.4-6ubuntu1.dsc
 bc297a8172fe4955e3e65d1e92c18c76 15780 python optional python-qt4_4.4.4-6ubuntu1.diff.gz
Original-Maintainer: Debian Python Modules Team <python-modules-team at lists.alioth.debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkoV3JUACgkQHajaM93NaGrz/ACfYTdm0FA8n56PZ5ksoB2+Wvhv
lxwAn1Xh6wfIpy7+hd0kIaQ7XUvAtRPR
=VtLa
-----END PGP SIGNATURE-----


More information about the Karmic-changes mailing list