[ubuntu/karmic] boost1.37 1.37.0-9ubuntu1 (Accepted)

Andrew Starr-Bochicchio a.starr.b at gmail.com
Sat May 2 15:00:34 BST 2009


boost1.37 (1.37.0-9ubuntu1) karmic; urgency=low

  * Merge from debian unstable (LP: #370186), remaining changes:
   - debian/rules: Update for Python 2.4/2.5 -> 2.5/2.6
    + Pass "--install-layout=deb" to "setup.py install" for pyste.
    + Change $(pyste_prefix) to $(pyste_root)
   - debian/rtupdate: Update for python2.6.
   - debian/control: Update XS-Python-Version 2.4/2.5 -> 2.5/2.6

boost1.37 (1.37.0-9) unstable; urgency=low

  * rtupdate: Handle versioned libboostX.Y-dbg.rtupdate properly.  Closes:
    #525378.

boost1.37 (1.37.0-8) unstable; urgency=low

  * rtupdate: Do not die if called for an unknown python version, just
    remove existing symlinks.  Closes: #520749.

  * control: Package -dbg is now in section debug.

boost1.37 (1.37.0-7) unstable; urgency=low

  * README.Debian: Add note about Boost.Test main() function.  Closes:
    #516879.

boost1.37 (1.37.0-6) unstable; urgency=low

  * patches/fix_eventfd_select_interrupter.patch: New.  Upstream patch
    r50961.  Closes: #519669.

  * control: Change libboost1.37-dev dependency libboost1.37-doc from
    Recommends to Suggests.  Recommends are often downloaded by default,
    suggests is more appropriate.  Closes: #517406.

boost1.37 (1.37.0-5) unstable; urgency=low

  * README.Debian:
  * libboost-python-dev.README.Debian: Revise, removing all the verbiage
    about single-threaded versions and decorated library names which was
    not relevant as of 1.37.0-1.

  * control: libboost1.37-dev depends on libboost-math1.37-dev.  Closes:
    #515079.  Update list of separate packages in description and
    Recommends line for libboost1.37-dev.

boost1.37 (1.37.0-4) unstable; urgency=low

  * patches/function-template.patch: New.  Fix misplaced #ifdef (thanks to
    Caolan McNamara for the patch at
    https://bugzilla.redhat.com/show_bug.cgi?id=477131).  Closes: #511073.

  * control:
  * rules: New packages libboost-mpi1.37.0 and libboost-mpi1.37-dev.
    Closes: #494832, #490242.  Thanks to Tilman Koschnick and Rutger ter
    Borg for their patches.  New -dev package conflicts and replaces
    libboost1.37-dev, since the headers were moved from the latter to the
    former.
  * patches/mpi-python.patch: The python bindings for Boost.MPI don't
    build; disable until I understand what's going on.

  * rules: Usage of "dh_clean -k" is deprecated in debhelper 7; replace
    with "dh_prep".

Date: Mon, 27 Apr 2009 15:27:57 +0100
Changed-By: Andrew Starr-Bochicchio <a.starr.b at gmail.com>
Maintainer: Ubuntu MOTU Developers <ubuntu-motu at lists.ubuntu.com>
Signed-By: James Westby <jw+debian at jameswestby.net>
https://launchpad.net/ubuntu/karmic/+source/boost1.37/1.37.0-9ubuntu1
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Mon, 27 Apr 2009 15:27:57 +0100
Source: boost1.37
Binary: libboost1.37-dbg libboost1.37-dev libboost1.37-doc libboost-date-time1.37.0 libboost-date-time1.37-dev libboost-filesystem1.37.0 libboost-filesystem1.37-dev libboost-graph1.37.0 libboost-graph1.37-dev libboost-iostreams1.37.0 libboost-iostreams1.37-dev libboost-math1.37.0 libboost-math1.37-dev libboost-mpi1.37.0 libboost-mpi1.37-dev libboost-program-options1.37.0 libboost-program-options1.37-dev libboost-python1.37.0 libboost-python1.37-dev libboost-regex1.37.0 libboost-regex1.37-dev libboost-serialization1.37.0 libboost-serialization1.37-dev libboost-signals1.37.0 libboost-signals1.37-dev libboost-system1.37.0 libboost-system1.37-dev libboost-test1.37.0 libboost-test1.37-dev libboost-thread1.37.0 libboost-thread1.37-dev libboost-wave1.37.0 libboost-wave1.37-dev
Architecture: source
Version: 1.37.0-9ubuntu1
Distribution: karmic
Urgency: low
Maintainer: Ubuntu MOTU Developers <ubuntu-motu at lists.ubuntu.com>
Changed-By: Andrew Starr-Bochicchio <a.starr.b at gmail.com>
Description: 
 libboost-date-time1.37-dev - set of date-time libraries based on generic programming concepts
 libboost-date-time1.37.0 - set of date-time libraries based on generic programming concepts
 libboost-filesystem1.37-dev - filesystem operations (portable paths, iteration over directories
 libboost-filesystem1.37.0 - filesystem operations (portable paths, iteration over directories
 libboost-graph1.37-dev - generic graph components and algorithms in C++
 libboost-graph1.37.0 - generic graph components and algorithms in C++
 libboost-iostreams1.37-dev - Boost.Iostreams Library development files
 libboost-iostreams1.37.0 - Boost.Iostreams Library
 libboost-math1.37-dev - Boost.Math Library development files
 libboost-math1.37.0 - Boost.Math Library
 libboost-mpi1.37-dev - C++ interface to the Message Passing Interface (MPI) - OpenMPI ve
 libboost-mpi1.37.0 - C++ interface to the Message Passing Interface (MPI) - OpenMPI ve
 libboost-program-options1.37-dev - program options library for C++
 libboost-program-options1.37.0 - program options library for C++
 libboost-python1.37-dev - Boost.Python Library development files
 libboost-python1.37.0 - Boost.Python Library
 libboost-regex1.37-dev - regular expression library for C++
 libboost-regex1.37.0 - regular expression library for C++
 libboost-serialization1.37-dev - serialization library for C++
 libboost-serialization1.37.0 - serialization library for C++
 libboost-signals1.37-dev - managed signals and slots library for C++
 libboost-signals1.37.0 - managed signals and slots library for C++
 libboost-system1.37-dev - Operating system (e.g. diagnostics support) library
 libboost-system1.37.0 - Operating system (e.g. diagnostics support) library
 libboost-test1.37-dev - components for writing and executing test suites
 libboost-test1.37.0 - components for writing and executing test suites
 libboost-thread1.37-dev - portable C++ multi-threading
 libboost-thread1.37.0 - portable C++ multi-threading
 libboost-wave1.37-dev - C99/C++ preprocessor library
 libboost-wave1.37.0 - C99/C++ preprocessor library
 libboost1.37-dbg - Boost C++ Libraries with debug symbols
 libboost1.37-dev - Boost C++ Libraries development files
 libboost1.37-doc - Boost.org libraries documentation
Closes: 490242 494832 511073 515079 516879 517406 519669 520749 525378
Launchpad-Bugs-Fixed: 370186
Changes: 
 boost1.37 (1.37.0-9ubuntu1) karmic; urgency=low
 .
   * Merge from debian unstable (LP: #370186), remaining changes:
    - debian/rules: Update for Python 2.4/2.5 -> 2.5/2.6
     + Pass "--install-layout=deb" to "setup.py install" for pyste.
     + Change $(pyste_prefix) to $(pyste_root)
    - debian/rtupdate: Update for python2.6.
    - debian/control: Update XS-Python-Version 2.4/2.5 -> 2.5/2.6
 .
 boost1.37 (1.37.0-9) unstable; urgency=low
 .
   * rtupdate: Handle versioned libboostX.Y-dbg.rtupdate properly.  Closes:
     #525378.
 .
 boost1.37 (1.37.0-8) unstable; urgency=low
 .
   * rtupdate: Do not die if called for an unknown python version, just
     remove existing symlinks.  Closes: #520749.
 .
   * control: Package -dbg is now in section debug.
 .
 boost1.37 (1.37.0-7) unstable; urgency=low
 .
   * README.Debian: Add note about Boost.Test main() function.  Closes:
     #516879.
 .
 boost1.37 (1.37.0-6) unstable; urgency=low
 .
   * patches/fix_eventfd_select_interrupter.patch: New.  Upstream patch
     r50961.  Closes: #519669.
 .
   * control: Change libboost1.37-dev dependency libboost1.37-doc from
     Recommends to Suggests.  Recommends are often downloaded by default,
     suggests is more appropriate.  Closes: #517406.
 .
 boost1.37 (1.37.0-5) unstable; urgency=low
 .
   * README.Debian:
   * libboost-python-dev.README.Debian: Revise, removing all the verbiage
     about single-threaded versions and decorated library names which was
     not relevant as of 1.37.0-1.
 .
   * control: libboost1.37-dev depends on libboost-math1.37-dev.  Closes:
     #515079.  Update list of separate packages in description and
     Recommends line for libboost1.37-dev.
 .
 boost1.37 (1.37.0-4) unstable; urgency=low
 .
   * patches/function-template.patch: New.  Fix misplaced #ifdef (thanks to
     Caolan McNamara for the patch at
     https://bugzilla.redhat.com/show_bug.cgi?id=477131).  Closes: #511073.
 .
   * control:
   * rules: New packages libboost-mpi1.37.0 and libboost-mpi1.37-dev.
     Closes: #494832, #490242.  Thanks to Tilman Koschnick and Rutger ter
     Borg for their patches.  New -dev package conflicts and replaces
     libboost1.37-dev, since the headers were moved from the latter to the
     former.
   * patches/mpi-python.patch: The python bindings for Boost.MPI don't
     build; disable until I understand what's going on.
 .
   * rules: Usage of "dh_clean -k" is deprecated in debhelper 7; replace
     with "dh_prep".
Checksums-Sha1: 
 b7402c41a049de0e5d79f286450ba34910921af3 2353 boost1.37_1.37.0-9ubuntu1.dsc
 678c31b3b7c774b7a859f0a7f601c5ad2d43cd80 193801 boost1.37_1.37.0-9ubuntu1.diff.gz
Checksums-Sha256: 
 89ef0c60752201c4819633c3fbbe038123778ae7d382cd49447d1ef4c2b06967 2353 boost1.37_1.37.0-9ubuntu1.dsc
 6cd60bfecea2b8f9015b6335f127084260d98250f3665010ce1d33e30bb8dcd3 193801 boost1.37_1.37.0-9ubuntu1.diff.gz
Files: 
 fa49439c93256a0ee1dc5ad2db78d3fd 2353 libs optional boost1.37_1.37.0-9ubuntu1.dsc
 a29f2ade070eadcbb034585ffff95d31 193801 libs optional boost1.37_1.37.0-9ubuntu1.diff.gz
Original-Maintainer: Debian Boost Team <pkg-boost-devel at lists.alioth.debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkn7TsAACgkQRej+37V3/hPIkACgi8gzB7bXZ/yzGQFEFv3jkaxh
+ZAAn3yZcN5PBOBlYlanPB/dlhOWIAuo
=hDAg
-----END PGP SIGNATURE-----


More information about the Karmic-changes mailing list