[ubuntu/karmic] libvirt 0.6.4-1ubuntu1 (Accepted)

Soren Hansen soren at ubuntu.com
Mon Jun 22 12:05:13 BST 2009


libvirt (0.6.4-1ubuntu1) karmic; urgency=low

  * Merge from debian unstable, remaining changes:
    - debian/control:
      + Don't build-depend on QEmu.
      + Add "XS-Debian-" prefix to Debian's Vcs headers.
      + Bump bridge-utils, dnsmasq-base, netcat-openbsd, and iptables
        to Depends of libvirt-bin.
      + s/interract/interact/g
      + Add versioned Conflicts/Replaces to libvirt0 for libvirt0-dbg,
        since we used to ship them as such.
    - 9000-delayed_iff_up_bridge.patch:
      Don't try to bring up the bridge before at least one interface has been
      added to it.
    - 9001-dont_clobber_existing_bridges.patch
      Assign the name of the virtual bridge dynamically to avoid interfering
      with existing bridges.
    - 9002-better_default_uri_virsh.patch:
      Default to qemu:///system if the user has write access to the libvirt
      socket, otherwise qemu:///session.
    - 9003-increase-logoutput-timeout.patch:
      increase timeout waiting for log output in src/qemu_driver.c, set to 30
      seconds, which 10x longer than before, and matches the disk-wait in
      mdadm. (LP #344400)
    - 9004-better-default-arch.patch:
      If a domain does not specify its architecture, attempt to match the host.
      (LP #344913)
    - 9005-libvirtd-group-name.patch:
      Rename libvirt group to libvirtd.
    - We call libxen-dev libxen3-dev, so change all references.

libvirt (0.6.4-1) unstable; urgency=low

  * [dd3adb2] Imported Upstream version 0.6.4
  * [2320162] update symbols file
  * [89c9720] remove bashism (Closes: #530122)
  * [30d86c1] drop patches fixed upstream:
        0005-don-t-crash-with-def-NULL.patch
        0006-Fix-QEMU-ARGV-detection-with-kvm-85.patch
        0007-Declare-support-for-QEMU-migration-in-capabilities.patch

libvirt (0.6.3-4) unstable; urgency=low

  * [3607f2f] Install libvirt_lxc that got list somewhere between our
              testbuilds. (Closes: #529578)
  * [070ddd5] install augeas lense
  * [c9b034d] install schema files

libvirt (0.6.3-3) unstable; urgency=low

  * [4087b7d] disable lxc on ia64 to work around FTBFS until we have
              access to a test machine
  * [df5f5a0] pull some kvm/qemu related patches from upstream
              (Closes: #529324)

libvirt (0.6.3-2) unstable; urgency=low

  * [35898d3] fix crash when libvirt_lxc is called without arguments
  * [449ca60] enable lxc support (Closes: #526718) - thanks to Daniel
              Pittman for testing this
  * [335a4e6] update description with supported virtualization solutions
  * [92eba47] delay libvirt-bin start until after avahi
  * [8ebd17d] update startup priorities due to changed libvirt-bin
               startup priority. Also add an LSB header. (Closes: #526944)

libvirt (0.6.3-1) unstable; urgency=low

  * [0cb2f83] Imported Upstream version 0.6.3
        * virtual box support
  * [06fe518] 0001-remove-RHism.diff.patch: use invoke-rc.d
  * [ec2fd52] drop patches merged upstream:
        * 0003-allow-libvirt-group-to-access-the-socket.patch  series
        * 0004-fix-Debian-specific-path-to-hvm-loader.patch
  * [6977bde] enable vbox support
  * [93c4423] add symbols file

libvirt (0.6.2-2) unstable; urgency=low

  * [031b9c1] Don't hardcode buffer size for getgrnam_r. Works around
              #520744 and fixes possible problems with implementations having
              _SC_GETGR_R_SIZE_MAX != 1024.
  * [bbe7743] respect log priority for qemu domain logs (Closes: #524145)
  * [a2e4cb0] don't rely on log_end_msg returning 0 this isn't the case
              with splashy. (Closes: #523712)
  * [ddfafda] move debug package into section debug

libvirt (0.6.2-1) unstable; urgency=low

  * [99fd06c] Imported Upstream version 0.6.2 (Closes: #521785)
  * [78cd5c8] drop /var/run/libvirt created by init script
  * [2a7cb3b] move startup of libvirtd after hal (Closes: #522310)
  * [b8707ed] bump standards version 0.8.1 (no changes necessary)

libvirt (0.6.1-1) unstable; urgency=low

  * [3be7341] Imported Upstream version 0.6.1
  * [38fde15] rediff Debian specific patches
  * [9b59a19] drop patches applied upstream:
        * 0004-Don-t-hardcode-ssh-port.patch
        * 0005-minimal-workaround-for-qemu-startup-race.patch
  * [95d4b7f] drop patches backported from upstream
        * 0009-libvirt_proxy-Fix-use-of-uninitalized-memory.patch
  * [8171d83] build-dep on module-init-tools so configure can figure out
    the path to modprobe

Date: Mon, 22 Jun 2009 11:14:57 +0200
Changed-By: Soren Hansen <soren at ubuntu.com>
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/karmic/+source/libvirt/0.6.4-1ubuntu1
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Mon, 22 Jun 2009 11:14:57 +0200
Source: libvirt
Binary: libvirt-bin libvirt0 libvirt0-dbg libvirt-doc libvirt-dev python-libvirt
Architecture: source
Version: 0.6.4-1ubuntu1
Distribution: karmic
Urgency: low
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Soren Hansen <soren at ubuntu.com>
Description: 
 libvirt-bin - the programs for the libvirt library
 libvirt-dev - development files for the libvirt library
 libvirt-doc - documentation for the libvirt library
 libvirt0   - library for interfacing with different virtualization systems
 libvirt0-dbg - library for interfacing with different virtualization systems
 python-libvirt - libvirt Python bindings
Closes: 521785 522310 523712 524145 526718 526944 529324 529578 530122
Changes: 
 libvirt (0.6.4-1ubuntu1) karmic; urgency=low
 .
   * Merge from debian unstable, remaining changes:
     - debian/control:
       + Don't build-depend on QEmu.
       + Add "XS-Debian-" prefix to Debian's Vcs headers.
       + Bump bridge-utils, dnsmasq-base, netcat-openbsd, and iptables
         to Depends of libvirt-bin.
       + s/interract/interact/g
       + Add versioned Conflicts/Replaces to libvirt0 for libvirt0-dbg,
         since we used to ship them as such.
     - 9000-delayed_iff_up_bridge.patch:
       Don't try to bring up the bridge before at least one interface has been
       added to it.
     - 9001-dont_clobber_existing_bridges.patch
       Assign the name of the virtual bridge dynamically to avoid interfering
       with existing bridges.
     - 9002-better_default_uri_virsh.patch:
       Default to qemu:///system if the user has write access to the libvirt
       socket, otherwise qemu:///session.
     - 9003-increase-logoutput-timeout.patch:
       increase timeout waiting for log output in src/qemu_driver.c, set to 30
       seconds, which 10x longer than before, and matches the disk-wait in
       mdadm. (LP #344400)
     - 9004-better-default-arch.patch:
       If a domain does not specify its architecture, attempt to match the host.
       (LP #344913)
     - 9005-libvirtd-group-name.patch:
       Rename libvirt group to libvirtd.
     - We call libxen-dev libxen3-dev, so change all references.
 .
 libvirt (0.6.4-1) unstable; urgency=low
 .
   * [dd3adb2] Imported Upstream version 0.6.4
   * [2320162] update symbols file
   * [89c9720] remove bashism (Closes: #530122)
   * [30d86c1] drop patches fixed upstream:
         0005-don-t-crash-with-def-NULL.patch
         0006-Fix-QEMU-ARGV-detection-with-kvm-85.patch
         0007-Declare-support-for-QEMU-migration-in-capabilities.patch
 .
 libvirt (0.6.3-4) unstable; urgency=low
 .
   * [3607f2f] Install libvirt_lxc that got list somewhere between our
               testbuilds. (Closes: #529578)
   * [070ddd5] install augeas lense
   * [c9b034d] install schema files
 .
 libvirt (0.6.3-3) unstable; urgency=low
 .
   * [4087b7d] disable lxc on ia64 to work around FTBFS until we have
               access to a test machine
   * [df5f5a0] pull some kvm/qemu related patches from upstream
               (Closes: #529324)
 .
 libvirt (0.6.3-2) unstable; urgency=low
 .
   * [35898d3] fix crash when libvirt_lxc is called without arguments
   * [449ca60] enable lxc support (Closes: #526718) - thanks to Daniel
               Pittman for testing this
   * [335a4e6] update description with supported virtualization solutions
   * [92eba47] delay libvirt-bin start until after avahi
   * [8ebd17d] update startup priorities due to changed libvirt-bin
                startup priority. Also add an LSB header. (Closes: #526944)
 .
 libvirt (0.6.3-1) unstable; urgency=low
 .
   * [0cb2f83] Imported Upstream version 0.6.3
         * virtual box support
   * [06fe518] 0001-remove-RHism.diff.patch: use invoke-rc.d
   * [ec2fd52] drop patches merged upstream:
         * 0003-allow-libvirt-group-to-access-the-socket.patch  series
         * 0004-fix-Debian-specific-path-to-hvm-loader.patch
   * [6977bde] enable vbox support
   * [93c4423] add symbols file
 .
 libvirt (0.6.2-2) unstable; urgency=low
 .
   * [031b9c1] Don't hardcode buffer size for getgrnam_r. Works around
               #520744 and fixes possible problems with implementations having
               _SC_GETGR_R_SIZE_MAX != 1024.
   * [bbe7743] respect log priority for qemu domain logs (Closes: #524145)
   * [a2e4cb0] don't rely on log_end_msg returning 0 this isn't the case
               with splashy. (Closes: #523712)
   * [ddfafda] move debug package into section debug
 .
 libvirt (0.6.2-1) unstable; urgency=low
 .
   * [99fd06c] Imported Upstream version 0.6.2 (Closes: #521785)
   * [78cd5c8] drop /var/run/libvirt created by init script
   * [2a7cb3b] move startup of libvirtd after hal (Closes: #522310)
   * [b8707ed] bump standards version 0.8.1 (no changes necessary)
 .
 libvirt (0.6.1-1) unstable; urgency=low
 .
   * [3be7341] Imported Upstream version 0.6.1
   * [38fde15] rediff Debian specific patches
   * [9b59a19] drop patches applied upstream:
         * 0004-Don-t-hardcode-ssh-port.patch
         * 0005-minimal-workaround-for-qemu-startup-race.patch
   * [95d4b7f] drop patches backported from upstream
         * 0009-libvirt_proxy-Fix-use-of-uninitalized-memory.patch
   * [8171d83] build-dep on module-init-tools so configure can figure out
     the path to modprobe
Checksums-Sha1: 
 598badd797b32a9432780aa6555542bb215109f1 1740 libvirt_0.6.4-1ubuntu1.dsc
 226c1ae968f7a3b1900c8b2f9d1a5c503bd4a961 7148934 libvirt_0.6.4.orig.tar.gz
 ae51a49ed54252739a7747c78aa8288c437f32e6 26895 libvirt_0.6.4-1ubuntu1.diff.gz
Checksums-Sha256: 
 899af7cf52e19b6764689e1950527c5deac2bd307dd904746b987c973aa20a9d 1740 libvirt_0.6.4-1ubuntu1.dsc
 c7d0bcc56d8b9d53847e3044f9abd25d9a650686d5bccceffa75cb50ac5b621e 7148934 libvirt_0.6.4.orig.tar.gz
 ec228e97ed2cfd6c8a506b3c15a569ab28c405afceeac9841d13c7b6ef953519 26895 libvirt_0.6.4-1ubuntu1.diff.gz
Files: 
 619028b60d587bc2ef7ff22e1ee99910 1740 libs optional libvirt_0.6.4-1ubuntu1.dsc
 344a6913a94582ea3ab0ad75a9bfef22 7148934 libs optional libvirt_0.6.4.orig.tar.gz
 0eb7cde5f431498cddcae624f4c9645d 26895 libs optional libvirt_0.6.4-1ubuntu1.diff.gz
Original-Maintainer: Debian Libvirt Maintainers <pkg-libvirt-maintainers at lists.alioth.debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAko/ZLcACgkQonjfXui9pOMCjwCcDgbus1IctEXU/NCUoiU41AIG
/C8AnjxidSl0AOubi6qrIdAT+5TNN75a
=faEJ
-----END PGP SIGNATURE-----


More information about the Karmic-changes mailing list