[ubuntu/karmic] gpac 0.4.5-0.3ubuntu1 (Accepted)

Julien Lavergne julien.lavergne at gmail.com
Thu Jul 9 22:40:14 BST 2009


gpac (0.4.5-0.3ubuntu1) karmic; urgency=low

  * Merge from debian-multimedia.org (LP: #354825).
   - Fix a double-free/heap corruption (LP: #135071).
  * Remaining Ubuntu changes :
   - Remove libamrnb-dev and libamrwb-dev build-depends. These packages don't
     exist in Ubuntu repositories.
   - Increment libgpac-dev Replaces: gpac version to 0.4.2~rc2-0ubuntu1
   - Build-depends on libxmlrpc-c3-dev because libxmlrpc-c-dev is not provided
     in the Ubuntu package.

gpac (0.4.5-0.3) unstable; urgency=low

  * Added a patch from Ubuntu to fix a crash in MP4Box (Thanks to Kees Cook).

gpac (0.4.5-0.2) unstable; urgency=low

  * Don't Build-Depends for now on libopenjpeg-dev for alpha.

gpac (0.4.5-0.1) unstable; urgency=low

  * New patch : Don't install library in /usr/lib64.
  * Build with '-fPIC -DPIC' for all arch.
  * Add more cflags (-I/usr/include/mozjs -DXP_UNIX) for amd64.

gpac (0.4.5-0.0) unstable; urgency=low

  * New upstream release.

gpac (0.4.4.svn20080612-0.1) unstable; urgency=low

  * Fix bad library symlink in -dev package.
  * Move libgpac-dev in libdevel section.

gpac (0.4.4.svn20080612-0.0) unstable; urgency=low

  * New cvs release.
  * Added libgpac-dev in Build-Conflicts.

gpac (0.4.4-0.5) unstable; urgency=low

  * Added ccache support.
  * Rebuild against latest ffmpeg libraries.

gpac (0.4.4-0.4) unstable; urgency=low

  * Rebuild agains't the latest libavformat.

Date: Fri, 01 May 2009 16:10:06 +0200
Changed-By: Julien Lavergne <julien.lavergne at gmail.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Signed-By: Andreas Moog <andreas-launchpad at warperbbs.de>
https://launchpad.net/ubuntu/karmic/+source/gpac/0.4.5-0.3ubuntu1
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Fri, 01 May 2009 16:10:06 +0200
Source: gpac
Binary: gpac libgpac0.4.5 libgpac-dev
Architecture: source
Version: 0.4.5-0.3ubuntu1
Distribution: karmic
Urgency: low
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Julien Lavergne <julien.lavergne at gmail.com>
Description: 
 gpac       - multimedia framework based on the MPEG-4 Systems standard
 libgpac-dev - multimedia framework based on the MPEG-4 Systems standard
 libgpac0.4.5 - multimedia framework based on the MPEG-4 Systems standard
Changes: 
 gpac (0.4.5-0.3ubuntu1) karmic; urgency=low
 .
   * Merge from debian-multimedia.org (LP: #354825).
    - Fix a double-free/heap corruption (LP: #135071).
   * Remaining Ubuntu changes :
    - Remove libamrnb-dev and libamrwb-dev build-depends. These packages don't
      exist in Ubuntu repositories.
    - Increment libgpac-dev Replaces: gpac version to 0.4.2~rc2-0ubuntu1
    - Build-depends on libxmlrpc-c3-dev because libxmlrpc-c-dev is not provided
      in the Ubuntu package.
 .
 gpac (0.4.5-0.3) unstable; urgency=low
 .
   * Added a patch from Ubuntu to fix a crash in MP4Box (Thanks to Kees Cook).
 .
 gpac (0.4.5-0.2) unstable; urgency=low
 .
   * Don't Build-Depends for now on libopenjpeg-dev for alpha.
 .
 gpac (0.4.5-0.1) unstable; urgency=low
 .
   * New patch : Don't install library in /usr/lib64.
   * Build with '-fPIC -DPIC' for all arch.
   * Add more cflags (-I/usr/include/mozjs -DXP_UNIX) for amd64.
 .
 gpac (0.4.5-0.0) unstable; urgency=low
 .
   * New upstream release.
 .
 gpac (0.4.4.svn20080612-0.1) unstable; urgency=low
 .
   * Fix bad library symlink in -dev package.
   * Move libgpac-dev in libdevel section.
 .
 gpac (0.4.4.svn20080612-0.0) unstable; urgency=low
 .
   * New cvs release.
   * Added libgpac-dev in Build-Conflicts.
 .
 gpac (0.4.4-0.5) unstable; urgency=low
 .
   * Added ccache support.
   * Rebuild against latest ffmpeg libraries.
 .
 gpac (0.4.4-0.4) unstable; urgency=low
 .
   * Rebuild agains't the latest libavformat.
Checksums-Sha1: 
 f7e7f57ee4238a858c0a30dd8cd1575a0a354f02 1541 gpac_0.4.5-0.3ubuntu1.dsc
 c6684761a9c74cdcdb58af40eddc9fc6d54dd79f 5850324 gpac_0.4.5.orig.tar.gz
 a280f0d2941b381305d9e2e6afd2b45288ba4a9c 4839 gpac_0.4.5-0.3ubuntu1.diff.gz
Checksums-Sha256: 
 94ac5d648495794aa7042380080d54510e77f4785513ed69614c89a3c026bd3c 1541 gpac_0.4.5-0.3ubuntu1.dsc
 871dcf74a73eeaf4e84f43a272b8eb4c907850dafaf329c677164a8bdb561856 5850324 gpac_0.4.5.orig.tar.gz
 dd5cb1ed86e6996cfe42b80057a1786c6e60a4d43bd56730e00f52e6021b68f2 4839 gpac_0.4.5-0.3ubuntu1.diff.gz
Files: 
 b77b6acf5049a30ee49407f2b2d80c4a 1541 graphics optional gpac_0.4.5-0.3ubuntu1.dsc
 ef9dd0910f6c3ab5e0aec99b45a721da 5850324 graphics optional gpac_0.4.5.orig.tar.gz
 21262a2f14b116101abc6df4ed79cda2 4839 graphics optional gpac_0.4.5-0.3ubuntu1.diff.gz
Launchpad-Bugs-Fixed: 135071 354825
Original-Maintainer: Christian Marillat <marillat at debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkpWYvAACgkQ06FgkPZwicTzIwCg5qCOpeGm1vutSubviGC3Gmyp
3w8AoJmUcFHSeyRerSoIRgC2PycOr8xy
=8uY0
-----END PGP SIGNATURE-----


More information about the Karmic-changes mailing list