<div dir="ltr">So I think its fine for giving feedback from client against a controller (new client, old controller). Though how often we want to warn, have a way to disable the warning (for how long, etc)?<div><br></div><div>The other side seems more difficult, as far as 2.0 client talking to a 2.4 controller. We could start assuming we're going to deprecate today, and just start writing the 2.4 client to warn if you're running against a 2.8+ controller.</div><div><br></div><div>I think as for what we actually *support* (as in, be willing to make a release if we break compatibility) is possibly even only 1 minor version.</div><div><br></div><div>It is also interesting to consider how we convey to users of the API (aside from the Juju client itself), that they are running against older versions of the Facades. They know that they are when they connect and inspect the available versions. So they *could* inform the user, but there isn't any sort of inherit pressure we put on them to do so.</div><div><br></div><div>I think saying that we offer "we will allow clients that are <1yr old to stay compatible with current controllers", and vice versa seems ok, and doesn't seem like a significant maintenance burden. (we could at least release a new 2.X if we broke compatibility with 2.(X-2).)</div><div><br></div><div>John</div><div>=:-></div><div><br></div></div><div class="gmail_extra"><br><div class="gmail_quote">On Mon, Oct 30, 2017 at 8:22 AM, Anastasia Macmood <span dir="ltr"><<a href="mailto:anastasia.macmood@canonical.com" target="_blank">anastasia.macmood@canonical.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Hi<br>
<br>
Now that we are settled on Juju 2, going forward we need to have a way<br>
to retire older minor versions in a user-friendly manner.<br>
<br>
We propose to use client/server version comparison to flag retiring<br>
versions in 3 distinct steps - deprecated, obsolete and unsupported.<br>
<br>
For example, we can determine that if your client version differs from<br>
your controller version by:<br>
<br>
  * 2 minor versions, you are running a deprecated back-end;<br>
  * 3 minor versions, you are running an obsolete back-end;<br>
  * 4+ minor versions, you are running an unsupported backend.<br>
<br>
In this world, it means that when you are running a 2.4 client, you will<br>
be told that the controller on:<br>
<br>
  * 2.2 is deprecated;<br>
  * 2.1 is obsolete;<br>
  * 2.0 is unsupported.<br>
<br>
This will be surfaced as a warning on 'juju status'.<br>
<br>
This approach will allow us to not just retire certain API versions, but<br>
also help triage bugs and set clear user expectations. Additional<br>
benefits for maintenance and support - we will not be carrying around<br>
huge amount of backward compatible code and craft... For example, does<br>
it really makes sense for us to carry around and cater for backward<br>
compatibility with Juju 2.0 when we are developing 2.6?<br>
<br>
Thoughts?<br>
<br>
Sincerely Yours,<br>
<br>
Anastasia<br>
<span class="HOEnZb"><font color="#888888"><br>
<br>
--<br>
Juju-dev mailing list<br>
<a href="mailto:Juju-dev@lists.ubuntu.com">Juju-dev@lists.ubuntu.com</a><br>
Modify settings or unsubscribe at: <a href="https://lists.ubuntu.com/mailman/listinfo/juju-dev" rel="noreferrer" target="_blank">https://lists.ubuntu.com/<wbr>mailman/listinfo/juju-dev</a><br>
</font></span></blockquote></div><br></div>