<HTML><HEAD>
<META content="text/html; charset=utf-8" http-equiv=Content-Type></HEAD>
<BODY>
<DIV>
<DIV style="FONT-SIZE: 11pt; FONT-FAMILY: Calibri,sans-serif">Not sure about the issue. But why not find out the bootstrap's node ip from MAAS and ssh to it directly with username ubuntu. </DIV></DIV>
<DIV dir=ltr>
<HR>
<SPAN style="FONT-SIZE: 11pt; FONT-FAMILY: Calibri,sans-serif; FONT-WEIGHT: bold">From: </SPAN><SPAN style="FONT-SIZE: 11pt; FONT-FAMILY: Calibri,sans-serif"><A href="mailto:martyn1211@gmail.com">Martyn Cross</A></SPAN><BR><SPAN style="FONT-SIZE: 11pt; FONT-FAMILY: Calibri,sans-serif; FONT-WEIGHT: bold">Sent: </SPAN><SPAN style="FONT-SIZE: 11pt; FONT-FAMILY: Calibri,sans-serif">‎22/‎04/‎2014 5:14 AM</SPAN><BR><SPAN style="FONT-SIZE: 11pt; FONT-FAMILY: Calibri,sans-serif; FONT-WEIGHT: bold">To: </SPAN><SPAN style="FONT-SIZE: 11pt; FONT-FAMILY: Calibri,sans-serif"><A href="mailto:juju@lists.ubuntu.com">juju@lists.ubuntu.com</A></SPAN><BR><SPAN style="FONT-SIZE: 11pt; FONT-FAMILY: Calibri,sans-serif; FONT-WEIGHT: bold">Subject: </SPAN><SPAN style="FONT-SIZE: 11pt; FONT-FAMILY: Calibri,sans-serif">MAAS Bootstrap</SPAN><BR><BR></DIV>
<DIV dir=ltr>Hi all, 
<DIV><BR></DIV>
<DIV>I'm currently trying to get Juju up and running with my MAAS setup.  I have got Juju working using the local provider and working perfectly.  However when I switch to maas and run juju bootstrap, all goes well until it runs apt on the node that it images and is configuring.  The following takes place, causing the bootstrap to fail:</DIV>
<DIV><BR></DIV>
<DIV>
<DIV>Ign <A href="http://archive.ubuntu.com">http://archive.ubuntu.com</A> trusty-backports/universe Translation-en_US</DIV>
<DIV>Fetched 7,214 kB in 14s (488 kB/s)</DIV>
<DIV>W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_trusty_main_binary-i386_Packages  Hash Sum mismatch</DIV>
<DIV><BR></DIV>
<DIV>W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_trusty_universe_binary-i386_Packages  Hash Sum mismatch</DIV>
<DIV><BR></DIV>
<DIV>E: Some index files failed to download. They have been ignored, or old ones used instead.</DIV>
<DIV><BR></DIV>
<DIV><BR></DIV>
<DIV>I have tried specifying precise as the default-series in my environment.yaml and confirmed that there are relevant images in the cluster, however trusty is still being pulled down from maas.</DIV>
<DIV><BR></DIV>
<DIV>As this is before the bootstrap is complete, I can't use juju ssh node to fix the issue myself.</DIV>
<DIV><BR></DIV>
<DIV>Is there something that I am missing or have I just channeled my inner power of breaking everything in obscure ways.  Any suggestions or advice would be appreciated.  Let me know if you need any specific info about the setup or config.</DIV>
<DIV><BR></DIV>
<DIV>Many thanks,</DIV>
<DIV>
<DIV dir=ltr>Martyn Cross.</DIV></DIV></DIV></DIV></BODY></HTML>