<div dir="ltr">I threw up a fresh 14.04 desktop vm and compared the sources.list, all of the urls there are prepended with 'us', unlike the node that is not prepended with anything.  I prepended gb to the problematic ones and it pulled down fine.<div>

<br></div><div>Guess that explains it then Nate!  </div><div><br></div><div>The normal apt mirror is still not working however, will check it again in the morning.</div><div><br></div><div>Thanks</div></div><div class="gmail_extra">

<br clear="all"><div><div dir="ltr">Martyn Cross</div></div>
<br><br><div class="gmail_quote">On 21 April 2014 23:21, Nate Finch <span dir="ltr"><<a href="mailto:nate.finch@canonical.com" target="_blank">nate.finch@canonical.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">

<p dir="ltr">I heard one of the mirrors for the apt packages was having problems today, with people getting the same sort of error.  You might want to retry, it should have been fixed by now. </p>
<div class="gmail_quote"><div><div class="h5">On Apr 21, 2014 6:19 PM, "Martyn Cross" <<a href="mailto:martyn1211@gmail.com" target="_blank">martyn1211@gmail.com</a>> wrote:<br type="attribution"></div></div>

<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div><div class="h5">
<div dir="ltr">About an hour ago I managed to get ssh going to it, for some reason I couldn't get the rsa key to work initially, came back after some frustration and a reboot for it to start working.  Currently battling it now, unfortunately I can't just drop the problematic repo's as one of them is the 'main' one, doing so takes out a lot of essential packages.  All I can find online is 4-5 unanswered questions from people getting the same error from the repo when going from ubuntu 13.10 to 14.04.<div>




<br></div><div>I guess I need to have another go at forcing it to an older version of Ubuntu for now.</div><div><br></div><div>Thanks<div class="gmail_extra">
<br><br><div class="gmail_quote">On 21 April 2014 23:05, Sameer Zeidat <span dir="ltr"><<a href="mailto:sameerz@yahoo.com" target="_blank">sameerz@yahoo.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">






<div>
<div>
<div style="FONT-SIZE:11pt;FONT-FAMILY:Calibri,sans-serif">Not sure about the issue. But why not find out the bootstrap's node ip from MAAS and ssh to it directly with username ubuntu. </div></div>
<div dir="ltr">
<hr>
<span style="FONT-SIZE:11pt;FONT-FAMILY:Calibri,sans-serif;FONT-WEIGHT:bold">From: </span><span style="FONT-SIZE:11pt;FONT-FAMILY:Calibri,sans-serif"><a href="mailto:martyn1211@gmail.com" target="_blank">Martyn Cross</a></span><br>




<span style="FONT-SIZE:11pt;FONT-FAMILY:Calibri,sans-serif;FONT-WEIGHT:bold">Sent: </span><span style="FONT-SIZE:11pt;FONT-FAMILY:Calibri,sans-serif">‎22/‎04/‎2014 5:14 AM</span><br><span style="FONT-SIZE:11pt;FONT-FAMILY:Calibri,sans-serif;FONT-WEIGHT:bold">To: </span><span style="FONT-SIZE:11pt;FONT-FAMILY:Calibri,sans-serif"><a href="mailto:juju@lists.ubuntu.com" target="_blank">juju@lists.ubuntu.com</a></span><br>




<span style="FONT-SIZE:11pt;FONT-FAMILY:Calibri,sans-serif;FONT-WEIGHT:bold">Subject: </span><span style="FONT-SIZE:11pt;FONT-FAMILY:Calibri,sans-serif">MAAS Bootstrap</span><br><br></div><div><div>
<div dir="ltr">Hi all, 
<div><br></div>
<div>I'm currently trying to get Juju up and running with my MAAS setup.  I have got Juju working using the local provider and working perfectly.  However when I switch to maas and run juju bootstrap, all goes well until it runs apt on the node that it images and is configuring.  The following takes place, causing the bootstrap to fail:</div>





<div><br></div>
<div>
<div>Ign <a href="http://archive.ubuntu.com" target="_blank">http://archive.ubuntu.com</a> trusty-backports/universe Translation-en_US</div>
<div>Fetched 7,214 kB in 14s (488 kB/s)</div>
<div>W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_trusty_main_binary-i386_Packages  Hash Sum mismatch</div>
<div><br></div>
<div>W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_trusty_universe_binary-i386_Packages  Hash Sum mismatch</div>
<div><br></div>
<div>E: Some index files failed to download. They have been ignored, or old ones used instead.</div>
<div><br></div>
<div><br></div>
<div>I have tried specifying precise as the default-series in my environment.yaml and confirmed that there are relevant images in the cluster, however trusty is still being pulled down from maas.</div>
<div><br></div>
<div>As this is before the bootstrap is complete, I can't use juju ssh node to fix the issue myself.</div>
<div><br></div>
<div>Is there something that I am missing or have I just channeled my inner power of breaking everything in obscure ways.  Any suggestions or advice would be appreciated.  Let me know if you need any specific info about the setup or config.</div>





<div><br></div>
<div>Many thanks,</div>
<div>
<div dir="ltr">Martyn Cross.</div></div></div></div></div></div></div></blockquote></div><br></div></div></div>
<br></div></div><span class="HOEnZb"><font color="#888888">--<br>
Juju mailing list<br>
<a href="mailto:Juju@lists.ubuntu.com" target="_blank">Juju@lists.ubuntu.com</a><br>
Modify settings or unsubscribe at: <a href="https://lists.ubuntu.com/mailman/listinfo/juju" target="_blank">https://lists.ubuntu.com/mailman/listinfo/juju</a><br>
<br></font></span></blockquote></div>
</blockquote></div><br></div>