<div dir="ltr">On Tue, Sep 10, 2013 at 10:17 AM, Andrew Wilkins <span dir="ltr"><<a href="mailto:andrew.wilkins@canonical.com" target="_blank">andrew.wilkins@canonical.com</a>></span> wrote:<br><div class="gmail_extra">

<div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex"><div dir="ltr"><div class="im">On Tue, Sep 10, 2013 at 4:18 PM, Andreas Hasenack <span dir="ltr"><<a href="mailto:andreas@canonical.com" target="_blank">andreas@canonical.com</a>></span> wrote:</div>

<div class="gmail_extra"><div class="gmail_quote"><div class="im">
<blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex"><div dir="ltr"><div class="gmail_extra"><div class="gmail_quote">

<div>The 10.0.3.53 "machine" is a new container I brought up manually with lxc-create and lxc-start. lxc-list above shows all containers, and it was the only one running. </div>


<div><br></div><div>Right now I have this output for that ls command:</div><div><div># ls /etc/init/juju*</div><div>/etc/init/juju-agent-andreas-local.conf  /etc/init/juju-db-andreas-local.conf</div></div></div></div></div>


</blockquote><div><br></div></div><div>As discussed on IRC: the command will be run in the target (the container), not the local host.</div><div class="im"><div> </div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex">


<div dir="ltr"><div class="gmail_extra"><div class="gmail_quote">
<div>
juju lxc is bootstrapped, but no units are running, and lxc-list shows my both containers stopped.</div></div></div></div></blockquote><div><br></div></div><div>I'm creating a new container on my laptop now, using your configuration. I'll let you know what I find.</div>


</div><br></div></div></blockquote><div><br></div><div>It's because of this ssh warning:</div><div><div>$ ssh 10.0.3.230 "ls /etc/init/ | grep juju.*\\.conf || exit 0"</div><div>Warning: Permanently added '10.0.3.230' (ECDSA) to the list of known hosts.</div>

</div><div>$</div><div><br></div><div>The code grabs both stderr and stdout and checks for len > 0:</div><div><div>    out, err := cmd.CombinedOutput()</div></div><div>(...)</div><div><div>    return len(strings.TrimSpace(string(out))) > 0, nil</div>

</div><div><br></div><div><br></div><div> </div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex"><div dir="ltr">

<div class="gmail_extra"></div><div class="gmail_extra">Cheers,</div><div class="gmail_extra">Andrew</div></div>
</blockquote></div><br></div></div>