MySQL charm: hook failed: "config-changed"

Daniele Stroppa daniele.stroppa at joyent.com
Tue Feb 4 13:55:56 UTC 2014


Maarten, Curtis,

I tried to deploy mysql on the local provider with as little as 256M of
memory, but I still get the same error.

Daniele


On Tue, Feb 4, 2014 at 12:22 PM, Curtis Hovey-Canonical <
curtis at canonical.com> wrote:

> On Tue, Feb 4, 2014 at 12:29 PM, Maarten Ectors
> <maarten.ectors at canonical.com> wrote:
> > In the past I had an issue with the MySQL charm whereby it had some
> > parameter set to 4GB and I did not have enough memory. I don't remember
> the
> > exact parameter but it is in the /etc/mysql/my.cnf. By reducing it to a
> > smaller number that fits. If this problem still exists then let me know
> and
> > we will file a bug...
>
> The error is ambiguous, something went wrong after mysql installed.
> This does however match what we saw when mysql didn't get enough
> memory.
>
> When I create deploy mysql on azure and ec2, i do
>     juju bootstrap --contraints "mem=2G" mysql
> For hp I give it 4G
>     juju bootstrap --contraints "mem=4G" mysql
>
> --
> Curtis Hovey
> Canonical Cloud Development and Operations
> http://launchpad.net/~sinzui
>
> --
> Juju mailing list
> Juju at lists.ubuntu.com
> Modify settings or unsubscribe at:
> https://lists.ubuntu.com/mailman/listinfo/juju
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/juju/attachments/20140204/4926abdd/attachment.html>


More information about the Juju mailing list