MAAS Bootstrap

Martyn Cross martyn1211 at gmail.com
Mon Apr 21 22:37:48 UTC 2014


I threw up a fresh 14.04 desktop vm and compared the sources.list, all of
the urls there are prepended with 'us', unlike the node that is not
prepended with anything.  I prepended gb to the problematic ones and it
pulled down fine.

Guess that explains it then Nate!

The normal apt mirror is still not working however, will check it again in
the morning.

Thanks

Martyn Cross


On 21 April 2014 23:21, Nate Finch <nate.finch at canonical.com> wrote:

> I heard one of the mirrors for the apt packages was having problems today,
> with people getting the same sort of error.  You might want to retry, it
> should have been fixed by now.
> On Apr 21, 2014 6:19 PM, "Martyn Cross" <martyn1211 at gmail.com> wrote:
>
>> About an hour ago I managed to get ssh going to it, for some reason I
>> couldn't get the rsa key to work initially, came back after some
>> frustration and a reboot for it to start working.  Currently battling it
>> now, unfortunately I can't just drop the problematic repo's as one of them
>> is the 'main' one, doing so takes out a lot of essential packages.  All I
>> can find online is 4-5 unanswered questions from people getting the same
>> error from the repo when going from ubuntu 13.10 to 14.04.
>>
>> I guess I need to have another go at forcing it to an older version of
>> Ubuntu for now.
>>
>> Thanks
>>
>>
>> On 21 April 2014 23:05, Sameer Zeidat <sameerz at yahoo.com> wrote:
>>
>>>  Not sure about the issue. But why not find out the bootstrap's node ip
>>> from MAAS and ssh to it directly with username ubuntu.
>>>  ------------------------------
>>> From: Martyn Cross <martyn1211 at gmail.com>
>>> Sent: ‎22/‎04/‎2014 5:14 AM
>>> To: juju at lists.ubuntu.com
>>> Subject: MAAS Bootstrap
>>>
>>> Hi all,
>>>
>>> I'm currently trying to get Juju up and running with my MAAS setup.  I
>>> have got Juju working using the local provider and working perfectly.
>>>  However when I switch to maas and run juju bootstrap, all goes well until
>>> it runs apt on the node that it images and is configuring.  The following
>>> takes place, causing the bootstrap to fail:
>>>
>>>  Ign http://archive.ubuntu.com trusty-backports/universe
>>> Translation-en_US
>>> Fetched 7,214 kB in 14s (488 kB/s)
>>> W: Failed to fetch
>>> gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_trusty_main_binary-i386_Packages
>>>  Hash Sum mismatch
>>>
>>> W: Failed to fetch
>>> gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_trusty_universe_binary-i386_Packages
>>>  Hash Sum mismatch
>>>
>>> E: Some index files failed to download. They have been ignored, or old
>>> ones used instead.
>>>
>>>
>>> I have tried specifying precise as the default-series in my
>>> environment.yaml and confirmed that there are relevant images in the
>>> cluster, however trusty is still being pulled down from maas.
>>>
>>> As this is before the bootstrap is complete, I can't use juju ssh node
>>> to fix the issue myself.
>>>
>>> Is there something that I am missing or have I just channeled my inner
>>> power of breaking everything in obscure ways.  Any suggestions or advice
>>> would be appreciated.  Let me know if you need any specific info about the
>>> setup or config.
>>>
>>> Many thanks,
>>>  Martyn Cross.
>>>
>>
>>
>> --
>> Juju mailing list
>> Juju at lists.ubuntu.com
>> Modify settings or unsubscribe at:
>> https://lists.ubuntu.com/mailman/listinfo/juju
>>
>>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/juju/attachments/20140421/475e2119/attachment.html>


More information about the Juju mailing list