MAAS Bootstrap

Martyn Cross martyn1211 at gmail.com
Mon Apr 21 19:13:31 UTC 2014


Hi all,

I'm currently trying to get Juju up and running with my MAAS setup.  I have
got Juju working using the local provider and working perfectly.  However
when I switch to maas and run juju bootstrap, all goes well until it runs
apt on the node that it images and is configuring.  The following takes
place, causing the bootstrap to fail:

Ign http://archive.ubuntu.com trusty-backports/universe Translation-en_US
Fetched 7,214 kB in 14s (488 kB/s)
W: Failed to fetch
gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_trusty_main_binary-i386_Packages
 Hash Sum mismatch

W: Failed to fetch
gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_trusty_universe_binary-i386_Packages
 Hash Sum mismatch

E: Some index files failed to download. They have been ignored, or old ones
used instead.


I have tried specifying precise as the default-series in my
environment.yaml and confirmed that there are relevant images in the
cluster, however trusty is still being pulled down from maas.

As this is before the bootstrap is complete, I can't use juju ssh node to
fix the issue myself.

Is there something that I am missing or have I just channeled my inner
power of breaking everything in obscure ways.  Any suggestions or advice
would be appreciated.  Let me know if you need any specific info about the
setup or config.

Many thanks,
Martyn Cross.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/juju/attachments/20140421/73657b21/attachment.html>


More information about the Juju mailing list