Moving from pyjuju to juju-core

Matthew Williams matthew.williams at
Tue Mar 5 19:23:14 UTC 2013

Thanks Dimiter, I tried your suggestions and I got the following error 
during bootstrapping:
JUJU environs: searching for tools compatible with version: 


On 05/03/13 18:25, Dimiter Naydenov wrote:
> Hash: SHA1
> On 5.03.2013 13:05, Matthew Williams wrote:
>> I've just started playing around with juju core and I'm having trouble getting going.
>> Here are some of my notes so far, hope folks are able to give me some
> pointers
>> I can't seem to setup a local environment. I get the following error:
>>> error: environment "local" has an unknown provider type "local"
> Local provider is not ready for use yet - it's being developed at the
> moment.
>> I can't specify an ec2-uri (to be able to use canonistack)
>>> error: ec2-uri: expected nothing, got "<uri>"
> If you want to use the openstack provider with canonistack, just source
> your novarc file with the credentials and do not specify anything in
> environments.yaml. If you want to explicitly provide the settings, try
> "juju init > ~/.juju/environments.yaml" (possibly backing up the
> original file first). You'll get a skeleton config for all providers,
> and just fill in your openstack credentials there.
>> When I tried to deploy my charm - which works on pyjuju I get "hook
> failed: install" however in the unit there is no /var/lib/juju/units
> directory which is where I would normally go to see the charm.log file.
> Where should I be going to see logs?
>> Thanks
>> Matt
>> -mattyw-
> Version: GnuPG v1.4.11 (GNU/Linux)
> Comment: Using GnuPG with Thunderbird -
> om2lARyzhDQi3U1vA4m3h6u6BtMGtwcUF2YNLt0xtXB7w4SMbYyhpCxsoyCnML3q
> Mqswsk3eP+Ug1COi86HdLPbe2+ay4INBhATXRMg19AozmFtNtZ+IfpIv/JD9XU6X
> J8ZJAd8D/WdV1UQNr+LyLIzgMTWOFQ/kroWWTqxmUaDFs0fLEFHEsT2yXEpp6q9w
> 3voN7A8i5fMqNPYYtc1psMdFGEpRQKjtXpEG4vR+7ipGKWshSVG+J+gmj9Ehx6wY
> EEXzj9oWVt3XPqLUEK4xYFuacZV/9wnFmjaaM4jkwFABNcxeAOvT7ApKd/1Tqes=
> =uaiB

More information about the Juju mailing list