Fwd: [ubuntu/oneiric] zookeeper 3.3.3+dfsg2-1 (Accepted)

Clint Byrum clint at ubuntu.com
Fri Jul 15 15:07:13 UTC 2011


Note! Zookeeper is now at the latest version in Oneiric.

txzookeeper was also accepted last week.

At this point, this means ensemble is fully usable and hostable from
oneiric, without the PPA.

W00t!

--- Begin forwarded message from James Page ---
From: James Page <james.page at ubuntu.com>
To: oneiric-changes <oneiric-changes at lists.ubuntu.com>
Date: Fri, 15 Jul 2011 13:19:59 -0000
Subject: [ubuntu/oneiric] zookeeper 3.3.3+dfsg2-1 (Accepted)

zookeeper (3.3.3+dfsg2-1) unstable; urgency=low

  * Re-enable python 2.7 modules (Closes: #633690):
    - debian/control: X-Python-Version: >= 2.6
  * debian/copyright: added EPL-1.0 for src/contrib/zooinspector/icons/*.
  * debian/patches/fixes/ZOOKEEPER-1033: Cherry picked patch from 3.4.0 
    so that headers for c bindings are installed to /usr/include/zookeeper.
  * Purged additional non-DFSG files from upstream source:
    - src/java/test/data/* : invalid snapshot and upgrade testing data.

zookeeper (3.3.3+dfsg1-1) unstable; urgency=low

  * New upstream release.
  * Resolve FTBFS on mips and hppa - platforms should not be supported 
    as zookeeper needs default-jdk >= 1:1.6 (Closes: #626020,#594970).
  * Added myself to Uploaders.
  * Removed Thomas Koch from Uploaders - thanks for all of your work.
  * Bumped Standards-Version: 3.9.2; no changes.
  * Transition to dh_python2.
  * Fixed FTBFS due to -Werror actually working and causing build 
    failures in gcc >= 4.6.1 (Closes: #625441).
  * debian/bin/zkPurgeTxnLog.sh: Switch DATADIR and DATALOGDIR to match
    parameter ordering in Zookeeper code (Closes: #601383) - thanks to 
    Paul Paradise for identifying this issue and the fix.
  * debian/copyright: upgrade to DEP-5 format.

Date: Fri,  15 Jul 2011 13:17:57 +0000
Changed-By: James Page <james.page at ubuntu.com>
Maintainer: Debian Java Maintainers <pkg-java-maintainers at lists.alioth.debian.org>
Origin: Debian/unstable
https://launchpad.net/ubuntu/oneiric/+source/zookeeper/3.3.3+dfsg2-1
Origin: Debian/unstable
Format: 1.7
Date: Fri,  15 Jul 2011 13:17:57 +0000
Source: zookeeper
Binary: libzookeeper-java, zookeeper, zookeeperd, libzookeeper-java-doc, libzookeeper2, libzookeeper-dev, zookeeper-bin, python-zookeeper
Architecture: source
Version: 3.3.3+dfsg2-1
Distribution: oneiric
Urgency: low
Maintainer: Debian Java Maintainers <pkg-java-maintainers at lists.alioth.debian.org>
Changed-By: James Page <james.page at ubuntu.com>
Description:
 zookeeper  - High-performance coordination service for distributed application
Closes: 594970 601383 625441 626020 633690
Files:
 e41b17e67c1372c92d4a2480916bc9e8 2343 java optional zookeeper_3.3.3+dfsg2-1.dsc
 407fff61b46dea7040d5bc629b25af97 23229 java optional zookeeper_3.3.3+dfsg2-1.debian.tar.gz
 d6225059fc278849fbccb584e1a53356 1567377 java optional zookeeper_3.3.3+dfsg2.orig.tar.gz
Changes:
 zookeeper (3.3.3+dfsg2-1) unstable; urgency=low
 .
   * Re-enable python 2.7 modules (Closes: #633690):
     - debian/control: X-Python-Version: >= 2.6
   * debian/copyright: added EPL-1.0 for src/contrib/zooinspector/icons/*.
   * debian/patches/fixes/ZOOKEEPER-1033: Cherry picked patch from 3.4.0 
     so that headers for c bindings are installed to /usr/include/zookeeper.
   * Purged additional non-DFSG files from upstream source:
     - src/java/test/data/* : invalid snapshot and upgrade testing data.
 .
 zookeeper (3.3.3+dfsg1-1) unstable; urgency=low
 .
   * New upstream release.
   * Resolve FTBFS on mips and hppa - platforms should not be supported 
     as zookeeper needs default-jdk >= 1:1.6 (Closes: #626020,#594970).
   * Added myself to Uploaders.
   * Removed Thomas Koch from Uploaders - thanks for all of your work.
   * Bumped Standards-Version: 3.9.2; no changes.
   * Transition to dh_python2.
   * Fixed FTBFS due to -Werror actually working and causing build 
     failures in gcc >= 4.6.1 (Closes: #625441).
   * debian/bin/zkPurgeTxnLog.sh: Switch DATADIR and DATALOGDIR to match
     parameter ordering in Zookeeper code (Closes: #601383) - thanks to 
     Paul Paradise for identifying this issue and the fix.
   * debian/copyright: upgrade to DEP-5 format.
--- End forwarded message ---




More information about the Ensemble mailing list