<div dir="ltr">OK, looks like we have general agreement that we can drop the . imports across the board. Would someone volunteer to fix it, using the short names of their choice, and we can bikeshed them in the CL if it really seems necessary?</div>
<div class="gmail_extra"><br><br><div class="gmail_quote">On Fri, Jun 28, 2013 at 12:13 PM, roger peppe <span dir="ltr"><<a href="mailto:rogpeppe@gmail.com" target="_blank">rogpeppe@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div class="im">On 28 Jun 2013 08:14, "John Meinel" <<a href="mailto:john@arbash-meinel.com">john@arbash-meinel.com</a>> wrote:<br>
><br>
> If you troll through code reviews where this was brought up, William proposed possibly using a common short name. So<br>
><br>
> import (<br>
>     gc "<a href="http://launchpad.net/gocheck" target="_blank">launchpad.net/gocheck</a>"<br>
>     jc "<a href="http://launchpad.net/juju-core/testing/checkers" target="_blank">launchpad.net/juju-core/testing/checkers</a>"<br>
> )<br>
<br>
</div>I originally thought that a single capital C might work well for the<br>
gocheck import identifier, as it won't alias any local variables or<br>
any types that I know of, and it's reasonably distinctive and<br>
suggestive. We could use JC for the juju checkers.<br>
<br>
func (suite) TestSomething(c *C.C) {<br>
   c.Assert(x, C.Equals, 0)<br>
}<br>
<br>
isn't too bad. I sympathise with ian's points about readability but I<br>
think consistency and accessibility are also important, and I don't<br>
think this will have a strong impact on readability.<br>
<br>
I suggest we try something like this (it shouldn't be too hard to do<br>
the change automatically) and see if the result seems ok.<br>
<div class="HOEnZb"><div class="h5"><br>
--<br>
Juju-dev mailing list<br>
<a href="mailto:Juju-dev@lists.ubuntu.com">Juju-dev@lists.ubuntu.com</a><br>
Modify settings or unsubscribe at: <a href="https://lists.ubuntu.com/mailman/listinfo/juju-dev" target="_blank">https://lists.ubuntu.com/mailman/listinfo/juju-dev</a><br>
</div></div></blockquote></div><br></div>