[ubuntu/jaunty] base-files 4.0.5ubuntu1 (Accepted)

Colin Watson cjwatson at ubuntu.com
Fri Oct 31 13:20:21 GMT 2008


base-files (4.0.5ubuntu1) jaunty; urgency=low

  * Resynchronise with Debian. Remaining changes:
    - Branding changes.
    - Add /etc/lsb-release file.
    - Add lsb-release-udeb package.
    - Record md5sums of unmodified /etc/profile versions so that we can
      upgrade it automatically.
    - Various bashrc extensions.
    - Restore order line in /etc/host.conf with a comment.
    - Add default /etc/networks file.
    - Implement LSB-3.1, 16.2 (/etc/profile.d).
    - Added information about the docs web page.
    - Update the motd upgrade handling to know about /etc/motd.tail.
    - Do not install /usr/local dirs with staff group writeability, as there
      are cases where somebody can become any user but root (like NFS).
    - Change permissions of kernels copied from the Live CD by Ubiquity
      1.9.4 thru 1.10.9.
    - Correct group ownership of files changed by Ubiquity 1.7.5 thru
      1.10.9.
  * /etc/issue, /etc/issue.net, /etc/lsb-release: Welcome to Intrepid!

base-files (4.0.5) unstable; urgency=low

  * Changed awk from Depends to Pre-Depends. Closes: #314571, #469552.
    This is required to make the awk virtual package to be truly essential,
    as only essential packages, their predependencies, and the dependencies
    of their predependencies are guaranteed to be "working at all times".
    Previously, the packaging system was allowed to remove an awk flavour
    and install another one in the middle of an upgrade, which may break
    packages using awk in their preinsts (and in fact, it happened).
    Tkanks a lot to Steve Langasek for clarifying this issue.
  * It's still soon to change /etc/debian_version. Please be patient.

Date: Fri, 31 Oct 2008 13:17:58 +0000
Changed-By: Colin Watson <cjwatson at ubuntu.com>
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Signed-By: Colin Watson <cjwatson at canonical.com>
https://launchpad.net/ubuntu/jaunty/+source/base-files/4.0.5ubuntu1
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Fri, 31 Oct 2008 13:17:58 +0000
Source: base-files
Binary: base-files lsb-release-udeb
Architecture: source
Version: 4.0.5ubuntu1
Distribution: jaunty
Urgency: low
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Colin Watson <cjwatson at ubuntu.com>
Description: 
 base-files - Debian base system miscellaneous files
 lsb-release-udeb - LSB release information
Closes: 314571 469552
Changes: 
 base-files (4.0.5ubuntu1) jaunty; urgency=low
 .
   * Resynchronise with Debian. Remaining changes:
     - Branding changes.
     - Add /etc/lsb-release file.
     - Add lsb-release-udeb package.
     - Record md5sums of unmodified /etc/profile versions so that we can
       upgrade it automatically.
     - Various bashrc extensions.
     - Restore order line in /etc/host.conf with a comment.
     - Add default /etc/networks file.
     - Implement LSB-3.1, 16.2 (/etc/profile.d).
     - Added information about the docs web page.
     - Update the motd upgrade handling to know about /etc/motd.tail.
     - Do not install /usr/local dirs with staff group writeability, as there
       are cases where somebody can become any user but root (like NFS).
     - Change permissions of kernels copied from the Live CD by Ubiquity
       1.9.4 thru 1.10.9.
     - Correct group ownership of files changed by Ubiquity 1.7.5 thru
       1.10.9.
   * /etc/issue, /etc/issue.net, /etc/lsb-release: Welcome to Intrepid!
 .
 base-files (4.0.5) unstable; urgency=low
 .
   * Changed awk from Depends to Pre-Depends. Closes: #314571, #469552.
     This is required to make the awk virtual package to be truly essential,
     as only essential packages, their predependencies, and the dependencies
     of their predependencies are guaranteed to be "working at all times".
     Previously, the packaging system was allowed to remove an awk flavour
     and install another one in the middle of an upgrade, which may break
     packages using awk in their preinsts (and in fact, it happened).
     Tkanks a lot to Steve Langasek for clarifying this issue.
   * It's still soon to change /etc/debian_version. Please be patient.
Checksums-Sha1: 
 d615725a61dd75d98480724d54353962280c1719 862 base-files_4.0.5ubuntu1.dsc
 7689b277eb59b8b6e71fcccde54b98f7d685eca4 68272 base-files_4.0.5ubuntu1.tar.gz
Checksums-Sha256: 
 bc4be9811236917785354e0026467e2e91d20618171acdf044e02d57e3c3eaf8 862 base-files_4.0.5ubuntu1.dsc
 1095ddfbe7ac19998e309f7f9d191e7f0f0c798c9684054919238e35288ecb5a 68272 base-files_4.0.5ubuntu1.tar.gz
Files: 
 a62b0499a328d0fd9f3b9eb92407d267 862 admin required base-files_4.0.5ubuntu1.dsc
 a929e328802c2592eeb8f6783112c845 68272 admin required base-files_4.0.5ubuntu1.tar.gz
Original-Maintainer: Santiago Vila <sanvila at debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Colin Watson <cjwatson at debian.org> -- Debian developer

iD8DBQFJCwXB9t0zAhD6TNERArHRAJ0a3yNyK/EKK5S+tewT35lJ+AvLWwCcDTYd
npMrueaqfSHCTY64iBQzNIU=
=b5JG
-----END PGP SIGNATURE-----


More information about the Jaunty-changes mailing list