[ubuntu/jaunty] curl 7.18.2-7ubuntu1 (Accepted)

Michael Vogt michael.vogt at ubuntu.com
Mon Nov 10 12:05:30 GMT 2008


curl (7.18.2-7ubuntu1) jaunty; urgency=low

  * Merge from debian unstable, remaining changes:
    - Drop the stunnel build dependency.
    - Drop the build-dependency on libdb4.5-dev
    - Add build-dependency on openssh-server
    - Drop libssh2-1-dev from libcurl4-openssl-dev's Depends.
    - Call automake-1.9 with --add-missing --copy --force
    - Added Recommends: on ca-certificate for curl package

curl (7.18.2-7) unstable; urgency=low

  * disable c-ares support again, no fix yet, just get stuff working again.

curl (7.18.2-6) unstable; urgency=low

  * enable c-ares support, with ipv6 support

curl (7.18.2-5) unstable; urgency=low

  * /usr/lib/pkgconfig/libcurl.pc: "pkg-config --libs libcurl" returns
    "-Wl, -z, defs" (Closes: #488701), closing same bug again for
    curl-config --libs  command

curl (7.18.2-4) unstable; urgency=medium

  * /usr/lib/pkgconfig/libcurl.pc: "pkg-config --libs libcurl" returns
    "-Wl, -z, defs" (Closes: #488701)

curl (7.18.2-3) unstable; urgency=low

  * removing c-ares from the dependencies

curl (7.18.2-2) unstable; urgency=medium

  * blanking the "dependency_libs" line in lib*.la file to keep all the listed libs
    from being linked to other libs linking to curl.
  * fixing miss-linking problem by specifying liblber as a configure argument
  * disabling c-ares again for stability reasons
  * correcting libgssapi linking in configure.ac (patch no_com_err)

Date: Mon, 10 Nov 2008 12:55:54 +0100
Changed-By: Michael Vogt <michael.vogt at ubuntu.com>
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/jaunty/+source/curl/7.18.2-7ubuntu1
-------------- next part --------------
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Mon, 10 Nov 2008 12:55:54 +0100
Source: curl
Binary: curl libcurl3 libcurl3-gnutls libcurl4-openssl-dev libcurl4-gnutls-dev libcurl3-dbg
Architecture: source
Version: 7.18.2-7ubuntu1
Distribution: jaunty
Urgency: medium
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Michael Vogt <michael.vogt at ubuntu.com>
Description: 
 curl       - Get a file from an HTTP, HTTPS or FTP server
 libcurl3   - Multi-protocol file transfer library (OpenSSL)
 libcurl3-dbg - libcurl compiled with debug symbols
 libcurl3-gnutls - Multi-protocol file transfer library (GnuTLS)
 libcurl4-gnutls-dev - Development files and documentation for libcurl (GnuTLS)
 libcurl4-openssl-dev - Development files and documentation for libcurl (OpenSSL)
Closes: 488701 488701
Changes: 
 curl (7.18.2-7ubuntu1) jaunty; urgency=low
 .
   * Merge from debian unstable, remaining changes:
     - Drop the stunnel build dependency.
     - Drop the build-dependency on libdb4.5-dev
     - Add build-dependency on openssh-server
     - Drop libssh2-1-dev from libcurl4-openssl-dev's Depends.
     - Call automake-1.9 with --add-missing --copy --force
     - Added Recommends: on ca-certificate for curl package
 .
 curl (7.18.2-7) unstable; urgency=low
 .
   * disable c-ares support again, no fix yet, just get stuff working again.
 .
 curl (7.18.2-6) unstable; urgency=low
 .
   * enable c-ares support, with ipv6 support
 .
 curl (7.18.2-5) unstable; urgency=low
 .
   * /usr/lib/pkgconfig/libcurl.pc: "pkg-config --libs libcurl" returns
     "-Wl, -z, defs" (Closes: #488701), closing same bug again for
     curl-config --libs  command
 .
 curl (7.18.2-4) unstable; urgency=medium
 .
   * /usr/lib/pkgconfig/libcurl.pc: "pkg-config --libs libcurl" returns
     "-Wl, -z, defs" (Closes: #488701)
 .
 curl (7.18.2-3) unstable; urgency=low
 .
   * removing c-ares from the dependencies
 .
 curl (7.18.2-2) unstable; urgency=medium
 .
   * blanking the "dependency_libs" line in lib*.la file to keep all the listed libs
     from being linked to other libs linking to curl.
   * fixing miss-linking problem by specifying liblber as a configure argument
   * disabling c-ares again for stability reasons
   * correcting libgssapi linking in configure.ac (patch no_com_err)
Checksums-Sha1: 
 fb54b41a30e45ed55e9ebd937b93ddc4bd2a364f 1483 curl_7.18.2-7ubuntu1.dsc
 991506e6b6d60fdf247d6bd193661b229c2f8b01 23960 curl_7.18.2-7ubuntu1.diff.gz
Checksums-Sha256: 
 6a1b4d1d3d9fe7e3634fc6982b214a1913df8252234b9cb5dba525ddb0373e4a 1483 curl_7.18.2-7ubuntu1.dsc
 384d9952de9e2884153fb3150ba06500120abcc8e17f80c6635ee6bcb4d372d9 23960 curl_7.18.2-7ubuntu1.diff.gz
Files: 
 0aca480a7ed165a1133972fabb21c342 1483 web optional curl_7.18.2-7ubuntu1.dsc
 894fe47a029ac33810c20bf0ab9225f6 23960 web optional curl_7.18.2-7ubuntu1.diff.gz
Original-Maintainer: Domenico Andreoli <cavok at debian.org>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkkYIewACgkQliSD4VZixzSqUQCfU09GBzGaQEZRr/sX4z3uh5jc
z5gAniKamu5EMopQzDkmoHYL58QqPvEX
=5hjV
-----END PGP SIGNATURE-----


More information about the Jaunty-changes mailing list