[ubuntu/jammy-proposed] glibc 2.35-0ubuntu2 (Accepted)

Michael Hudson-Doyle michael.hudson at ubuntu.com
Fri Mar 4 02:39:26 UTC 2022


glibc (2.35-0ubuntu2) jammy; urgency=medium

  * d/patches/arm/local-vfp-sysdeps.diff: Restore, and add another EABI
    attribute to hopefully avoid upsetting current binutils.
  * debian/debhelper.in/libc.preinst: drop the check for kernel release
    > 255 now that glibc and preinstall script are fixed. (LP: #1962225)
  * Fix "./debian/rules update-from-upstream" to replace rather than append to
    git-updates.diff.
  * Update d/patches/git-updates.diff:
    - linux: fix accuracy of get_nprocs and get_nprocs_conf [BZ #28865]
    - linux: Use socket-constants-time64.h on tst-socket-timestamp-compat
    - string: Add a testcase for wcsncmp with SIZE_MAX [BZ #28755]
    - x86: Fallback {str|wcs}cmp RTM in the ncmp overflow case [BZ #28896]
    - x86: Test wcscmp RTM in the wcsncmp overflow case [BZ #28896]
    - x86: Fix TEST_NAME to make it a string in tst-strncmp-rtm.c
    - elf: Check invalid hole in PT_LOAD segments [BZ #28838]
    - elf: Replace tst-audit24bmod2.so with tst-audit24bmod2
    - resolv: Fix tst-resolv tests for 2.35 ABIs and later
    - localedef: Update LC_MONETARY handling (Bug 28845)
    - localedata: Do not generate output if warnings were present.
    - localedef: Handle symbolic links when generating locale-archive
    - nptl: Fix cleanups for stack grows up [BZ# 28899]
  * Remove tst-p_align3 from xfails.

Date: Fri, 04 Mar 2022 15:38:35 +1300
Changed-By: Michael Hudson-Doyle <michael.hudson at ubuntu.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/+source/glibc/2.35-0ubuntu2
-------------- next part --------------
Format: 1.8
Date: Fri, 04 Mar 2022 15:38:35 +1300
Source: glibc
Built-For-Profiles: noudeb
Architecture: source
Version: 2.35-0ubuntu2
Distribution: jammy
Urgency: medium
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Michael Hudson-Doyle <michael.hudson at ubuntu.com>
Launchpad-Bugs-Fixed: 1962225
Changes:
 glibc (2.35-0ubuntu2) jammy; urgency=medium
 .
   * d/patches/arm/local-vfp-sysdeps.diff: Restore, and add another EABI
     attribute to hopefully avoid upsetting current binutils.
   * debian/debhelper.in/libc.preinst: drop the check for kernel release
     > 255 now that glibc and preinstall script are fixed. (LP: #1962225)
   * Fix "./debian/rules update-from-upstream" to replace rather than append to
     git-updates.diff.
   * Update d/patches/git-updates.diff:
     - linux: fix accuracy of get_nprocs and get_nprocs_conf [BZ #28865]
     - linux: Use socket-constants-time64.h on tst-socket-timestamp-compat
     - string: Add a testcase for wcsncmp with SIZE_MAX [BZ #28755]
     - x86: Fallback {str|wcs}cmp RTM in the ncmp overflow case [BZ #28896]
     - x86: Test wcscmp RTM in the wcsncmp overflow case [BZ #28896]
     - x86: Fix TEST_NAME to make it a string in tst-strncmp-rtm.c
     - elf: Check invalid hole in PT_LOAD segments [BZ #28838]
     - elf: Replace tst-audit24bmod2.so with tst-audit24bmod2
     - resolv: Fix tst-resolv tests for 2.35 ABIs and later
     - localedef: Update LC_MONETARY handling (Bug 28845)
     - localedata: Do not generate output if warnings were present.
     - localedef: Handle symbolic links when generating locale-archive
     - nptl: Fix cleanups for stack grows up [BZ# 28899]
   * Remove tst-p_align3 from xfails.
Checksums-Sha1:
 fd9fa8e5aebc123d237c86b62282d2fb1be0f8d1 8876 glibc_2.35-0ubuntu2.dsc
 809d0cbe991318a7aa82f8631eaf26f546853e2e 885820 glibc_2.35-0ubuntu2.debian.tar.xz
 61566e34fa22a0efa30b6a65867e3effdcec3627 7890 glibc_2.35-0ubuntu2_source.buildinfo
Checksums-Sha256:
 662350d5bd202ff6045a2e8a33b0f709418366ded37c38feef982486d8a8786d 8876 glibc_2.35-0ubuntu2.dsc
 e3ffc2cbe2d096c43ea36e85d717475a1c24afbb7ea2ba112c74678c5c49992b 885820 glibc_2.35-0ubuntu2.debian.tar.xz
 4dac4bfb1f3e21929f96e68e12a07f3665a9c62a1c36dc97b7ef38250f2e53b7 7890 glibc_2.35-0ubuntu2_source.buildinfo
Files:
 2b402f894634616d0a8c5f19e42c8e46 8876 libs required glibc_2.35-0ubuntu2.dsc
 b202e8227cec55010eb61a87884271d2 885820 libs required glibc_2.35-0ubuntu2.debian.tar.xz
 1dc89f4c16d8b4aa8d1b06db608b063c 7890 libs required glibc_2.35-0ubuntu2_source.buildinfo
Original-Maintainer: GNU Libc Maintainers <debian-glibc at lists.debian.org>
Original-Vcs-Browser: https://salsa.debian.org/glibc-team/glibc
Original-Vcs-Git: https://salsa.debian.org/glibc-team/glibc.git


More information about the jammy-changes mailing list