[ubuntu/jammy-proposed] apparmor 3.0.4-1ubuntu1 (Accepted)

Alex Murray alex.murray at canonical.com
Tue Feb 22 11:02:16 UTC 2022


apparmor (3.0.4-1ubuntu1) jammy; urgency=medium

  * Merge from Debian unstable; remaining changes:
    - Drop the following patches that have been included in the upstream
      release or which Debian has also included:
      - d/p/ubuntu/adjust-for-ibus-1.5.22.patch
      - d/p/ubuntu/0011-add-mctp-network-protocol.patch
    - Refresh
      d/p/regression-tests-fix-aa_policy_cache-when-using-syst.patch to the
      official version from upstream
    - d/p/u/samba-systemd-interaction.patch: allow smbd to interact with
      systemd
    - d/p/u/libnss-systemd.patch: allow accessing the libnss-systemd
      VarLink sockets and DBus APIs
    - Disable lto builds
    - Fix autotest test-aa-notify.py
      - d/p/ubuntu/fix-test-aa-notify.patch
    - Drop outdated lintian-overrides

apparmor (3.0.4-1) unstable; urgency=medium

  * New upstream release
  * apparmor-profiles: install new samba-bgqd profile
  * Drop backported patches that are now obsolete
  * debian/allow-access-to-ibus-socket.patch: drop support for pre-Bullseye
    ibus path
  * Declare compliance with Policy 4.6.0.1
  * Drop XS- prefix for adopted Python-Version control field
  * Add new symbols

apparmor (3.0.3-6) unstable; urgency=medium

  * debian/rules: let "set -e" take effect (Closes: #998843)
  * Add support for Python 3.10 (Closes: #998686):
    - upstream-ab4cfb5e-replace-distutils-with-setuptools.patch: new patch,
      edited to drop changes to upstream .gitignore.
    - Add build-dependency on python3-setuptools

apparmor (3.0.3-5) unstable; urgency=medium

  [ Debian Janitor ]
  * Remove constraints unnecessary since stretch.

  [ Helmut Grohne ]
  * Make the package cross-buildable (Closes: #984582):
    - Multiarchify python Build-Depends
    - Let dh_auto_build pass cross tools to make
    - Annotate perl build-dependency with !nocheck

  [ intrigeri ]
  * Remove obsolete libapparmor-perl on upgrade

apparmor (3.0.3-4) unstable; urgency=medium

  * Merge apparmor-easyprof into apparmor-utils (Closes: #972880)
  * Make apparmor-utils and python3-apparmor arch:all (Closes: #972881)

apparmor (3.0.3-3) unstable; urgency=medium

  * Adjust gbp.conf and Vcs-* control fields for 3.0.x now being in sid.
  * Stop building the libapparmor-perl binary package (Closes: #993565)
  * Update Lintian overrides
  * Add B-D on dh-sequence-python3, to workaround #996089 in Lintian
  * B-D: python3-all → python3-all:any, to appease Lintian

apparmor (3.0.3-2) unstable; urgency=medium

  * Upload to unstable

apparmor (3.0.3-1) experimental; urgency=medium

  * New upstream release
  * Drop debian/Revert-libapparmor-fixing-setup.py-call-when-crosscompili.patch:
    obsolete
  * Refresh patches
  * Merge changes from sid, up to 2.13.6-10
  * upstream-6cfc6eee-python-3.10.patch: new patch,
    for compatibility with Python 3.10

Date: Tue, 22 Feb 2022 10:13:44 +1030
Changed-By: Alex Murray <alex.murray at canonical.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/+source/apparmor/3.0.4-1ubuntu1
-------------- next part --------------
Format: 1.8
Date: Tue, 22 Feb 2022 10:13:44 +1030
Source: apparmor
Built-For-Profiles: noudeb
Architecture: source
Version: 3.0.4-1ubuntu1
Distribution: jammy
Urgency: medium
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Alex Murray <alex.murray at canonical.com>
Closes: 972880 972881 984582 993565 998686 998843
Changes:
 apparmor (3.0.4-1ubuntu1) jammy; urgency=medium
 .
   * Merge from Debian unstable; remaining changes:
     - Drop the following patches that have been included in the upstream
       release or which Debian has also included:
       - d/p/ubuntu/adjust-for-ibus-1.5.22.patch
       - d/p/ubuntu/0011-add-mctp-network-protocol.patch
     - Refresh
       d/p/regression-tests-fix-aa_policy_cache-when-using-syst.patch to the
       official version from upstream
     - d/p/u/samba-systemd-interaction.patch: allow smbd to interact with
       systemd
     - d/p/u/libnss-systemd.patch: allow accessing the libnss-systemd
       VarLink sockets and DBus APIs
     - Disable lto builds
     - Fix autotest test-aa-notify.py
       - d/p/ubuntu/fix-test-aa-notify.patch
     - Drop outdated lintian-overrides
 .
 apparmor (3.0.4-1) unstable; urgency=medium
 .
   * New upstream release
   * apparmor-profiles: install new samba-bgqd profile
   * Drop backported patches that are now obsolete
   * debian/allow-access-to-ibus-socket.patch: drop support for pre-Bullseye
     ibus path
   * Declare compliance with Policy 4.6.0.1
   * Drop XS- prefix for adopted Python-Version control field
   * Add new symbols
 .
 apparmor (3.0.3-6) unstable; urgency=medium
 .
   * debian/rules: let "set -e" take effect (Closes: #998843)
   * Add support for Python 3.10 (Closes: #998686):
     - upstream-ab4cfb5e-replace-distutils-with-setuptools.patch: new patch,
       edited to drop changes to upstream .gitignore.
     - Add build-dependency on python3-setuptools
 .
 apparmor (3.0.3-5) unstable; urgency=medium
 .
   [ Debian Janitor ]
   * Remove constraints unnecessary since stretch.
 .
   [ Helmut Grohne ]
   * Make the package cross-buildable (Closes: #984582):
     - Multiarchify python Build-Depends
     - Let dh_auto_build pass cross tools to make
     - Annotate perl build-dependency with !nocheck
 .
   [ intrigeri ]
   * Remove obsolete libapparmor-perl on upgrade
 .
 apparmor (3.0.3-4) unstable; urgency=medium
 .
   * Merge apparmor-easyprof into apparmor-utils (Closes: #972880)
   * Make apparmor-utils and python3-apparmor arch:all (Closes: #972881)
 .
 apparmor (3.0.3-3) unstable; urgency=medium
 .
   * Adjust gbp.conf and Vcs-* control fields for 3.0.x now being in sid.
   * Stop building the libapparmor-perl binary package (Closes: #993565)
   * Update Lintian overrides
   * Add B-D on dh-sequence-python3, to workaround #996089 in Lintian
   * B-D: python3-all → python3-all:any, to appease Lintian
 .
 apparmor (3.0.3-2) unstable; urgency=medium
 .
   * Upload to unstable
 .
 apparmor (3.0.3-1) experimental; urgency=medium
 .
   * New upstream release
   * Drop debian/Revert-libapparmor-fixing-setup.py-call-when-crosscompili.patch:
     obsolete
   * Refresh patches
   * Merge changes from sid, up to 2.13.6-10
   * upstream-6cfc6eee-python-3.10.patch: new patch,
     for compatibility with Python 3.10
Checksums-Sha1:
 bc71a28c5d4d6a32c8b5fb559ace433038f28cd4 3243 apparmor_3.0.4-1ubuntu1.dsc
 aa5e5a84f5bfe9f621ee3d6cff1caffd95fbd825 7796852 apparmor_3.0.4.orig.tar.gz
 655b4b5165deb51eff7a3ed44702a2b66e5551b5 870 apparmor_3.0.4.orig.tar.gz.asc
 ebdfc9af4b5ff21f524e92c84dc0c4283a2d24fd 93664 apparmor_3.0.4-1ubuntu1.debian.tar.xz
 0092292234878691371045edbd7665b47d6c601f 8194 apparmor_3.0.4-1ubuntu1_source.buildinfo
Checksums-Sha256:
 3ada666482a24bebc89fbdf8563a895c4a2aa6e17928721e2dda2f8eea47d1cd 3243 apparmor_3.0.4-1ubuntu1.dsc
 09bf48d7a171f9790c39a1404bad105a788934cfe77b7490c7f5c63c2576b725 7796852 apparmor_3.0.4.orig.tar.gz
 fc5d5cfb71dd48e8e8a5321f84359e3131f9e5780804d154ea769d543c35be61 870 apparmor_3.0.4.orig.tar.gz.asc
 ed37b88b4403811d19aa4d966ba2d8b847fb6edd326595e8e251bbed2b93eb37 93664 apparmor_3.0.4-1ubuntu1.debian.tar.xz
 1e821d966dce7aeb6c269ab5bffd40b3a0b429231c52c261d17db75f9571d31d 8194 apparmor_3.0.4-1ubuntu1_source.buildinfo
Files:
 e0c4c32959808e7337ac257326ce02a8 3243 admin optional apparmor_3.0.4-1ubuntu1.dsc
 5215a5751a90a45149c699fc3e61a6e8 7796852 admin optional apparmor_3.0.4.orig.tar.gz
 f6525989eeae9caf6474dc41e697b54a 870 admin optional apparmor_3.0.4.orig.tar.gz.asc
 515482e419145af718095d25173440ec 93664 admin optional apparmor_3.0.4-1ubuntu1.debian.tar.xz
 7f9b795a710d908dd75f035dccb325b6 8194 admin optional apparmor_3.0.4-1ubuntu1_source.buildinfo
Original-Maintainer: Debian AppArmor Team <pkg-apparmor-team at lists.alioth.debian.org>


More information about the jammy-changes mailing list