[ubuntu/jammy-proposed] brltty 6.4-2ubuntu1 (Accepted)

Olivier Tilloy olivier.tilloy at canonical.com
Wed Nov 17 12:20:14 UTC 2021


brltty (6.4-2ubuntu1) jammy; urgency=medium

  * Resynchronize on Debian (fixes LP: #1950488)
    - Dropped delta:
      + udeb-specific changes, because Ubuntu doesn't build udebs any longer
        (LP: #1884836)
      + Ubuntu-specific entries in deprecated debian/NEWS file
      + JAVA_HOME additions to debian/rules (unneeded)
      + noudeb profiles changes to debian/{control,rules} that were upstreamed
      + changes to debian/{brltty,xbrlapi}.manpages that were upstreamed
      + debian/brltty.sh that replaced /sbin/brltty by /bin/brltty
    - Remaining changes:
      + add brltty-setup
        - debian/brltty-setup
        - debian/brltty.install
        - debian/rules
      + add initramfs integration to run brltty-setup if necessary before
        plymouth starts
        - debian/control
        - debian/initramfs/brltty.sh
        - debian/initramfs/hooks/brltty.in
        - debian/initramfs/scripts/init-premount/brltty
        - debian/initramfs/scripts/init-top/brltty
        - debian/brltty.dirs
        - debian/brltty.install
        - debian/brltty.postinst
      + add ubiquity integration to propagate any brltty configuration to the
        target system
        - debian/31brltty
        - debian/brltty.dirs
        - debian/brltty.install
      + add udev rules file that uses brltty-udev.service to activate via
        systemd
        - debian/brltty-udev.service
        - debian/brltty.dirs
        - debian/brltty.udev.rules
        - debian/rules
      + disable brltty.service by default, but enable it if the user configures
        Braille at install time for a non-USB display
        - debian/31brltty
        - debian/rules
      + don't install /etc/brltty.conf in the package
        - debian/31brltty
  * Rebase udev rules (debian/brltty.udev.rules) on upstream ones

Date: Wed, 17 Nov 2021 13:15:55 +0100
Changed-By: Olivier Tilloy <olivier.tilloy at canonical.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/+source/brltty/6.4-2ubuntu1
-------------- next part --------------
Format: 1.8
Date: Wed, 17 Nov 2021 13:15:55 +0100
Source: brltty
Built-For-Profiles: noudeb
Architecture: source
Version: 6.4-2ubuntu1
Distribution: jammy
Urgency: medium
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Olivier Tilloy <olivier.tilloy at canonical.com>
Launchpad-Bugs-Fixed: 1884836 1950488
Changes:
 brltty (6.4-2ubuntu1) jammy; urgency=medium
 .
   * Resynchronize on Debian (fixes LP: #1950488)
     - Dropped delta:
       + udeb-specific changes, because Ubuntu doesn't build udebs any longer
         (LP: #1884836)
       + Ubuntu-specific entries in deprecated debian/NEWS file
       + JAVA_HOME additions to debian/rules (unneeded)
       + noudeb profiles changes to debian/{control,rules} that were upstreamed
       + changes to debian/{brltty,xbrlapi}.manpages that were upstreamed
       + debian/brltty.sh that replaced /sbin/brltty by /bin/brltty
     - Remaining changes:
       + add brltty-setup
         - debian/brltty-setup
         - debian/brltty.install
         - debian/rules
       + add initramfs integration to run brltty-setup if necessary before
         plymouth starts
         - debian/control
         - debian/initramfs/brltty.sh
         - debian/initramfs/hooks/brltty.in
         - debian/initramfs/scripts/init-premount/brltty
         - debian/initramfs/scripts/init-top/brltty
         - debian/brltty.dirs
         - debian/brltty.install
         - debian/brltty.postinst
       + add ubiquity integration to propagate any brltty configuration to the
         target system
         - debian/31brltty
         - debian/brltty.dirs
         - debian/brltty.install
       + add udev rules file that uses brltty-udev.service to activate via
         systemd
         - debian/brltty-udev.service
         - debian/brltty.dirs
         - debian/brltty.udev.rules
         - debian/rules
       + disable brltty.service by default, but enable it if the user configures
         Braille at install time for a non-USB display
         - debian/31brltty
         - debian/rules
       + don't install /etc/brltty.conf in the package
         - debian/31brltty
   * Rebase udev rules (debian/brltty.udev.rules) on upstream ones
Checksums-Sha1:
 81e736a33ce6435c4e8674951910334451f0575f 3060 brltty_6.4-2ubuntu1.dsc
 101313e5ebd04f3996d60c81357817cae761dcd3 4245092 brltty_6.4.orig.tar.xz
 f1b9d953702d23b85d9c61d9f85a86493d291cd4 37720 brltty_6.4-2ubuntu1.debian.tar.xz
 b0a994bc6d5e531a699b8533cd0c3c504e084f3e 12497 brltty_6.4-2ubuntu1_source.buildinfo
Checksums-Sha256:
 e6ff18fa2ba28d3ac224c41b27e35833692ef130b4328b4136cd300e0f2de6be 3060 brltty_6.4-2ubuntu1.dsc
 e7ddd195b4b0aec23d4085b9edadeea21670cff7f8df8686552860aef5a29d3a 4245092 brltty_6.4.orig.tar.xz
 bc9be8928b8322d368673309442a4a7a71ef8e3a2dcf813319f471e44a5c1415 37720 brltty_6.4-2ubuntu1.debian.tar.xz
 a15f4b8e1a8e8c3eba8e7d8937bee246c3f9487c94e8d7d49fbb011e30c66a32 12497 brltty_6.4-2ubuntu1_source.buildinfo
Files:
 a0c52108f4459062f8882626029d5e37 3060 admin optional brltty_6.4-2ubuntu1.dsc
 c159cb96d4656961c2fbd851ed0b8526 4245092 admin optional brltty_6.4.orig.tar.xz
 2427754eab007a130a74aaa4b10f0f05 37720 admin optional brltty_6.4-2ubuntu1.debian.tar.xz
 476bda6652cd4ccde1beb1bfa5090da4 12497 admin optional brltty_6.4-2ubuntu1_source.buildinfo
Original-Maintainer: Debian Accessibility Team <pkg-a11y-devel at alioth-lists.debian.net>


More information about the jammy-changes mailing list