[ubuntu/jammy-proposed] strongswan 5.9.4-1ubuntu1 (Accepted)

Paride Legovini paride at ubuntu.com
Tue Nov 16 10:08:16 UTC 2021


strongswan (5.9.4-1ubuntu1) jammy; urgency=medium

  * Merge with Debian unstable. Remaining changes:
    - d/control: strongswan-starter hard-depends on strongswan-charon,
      therefore bump the dependency from Recommends to Depends. At the same
      time avoid a circular dependency by dropping
      strongswan-charon->strongswan-starter from Depends to Recommends as the
      binaries can work without the services but not vice versa.
    - re-add post-quantum encryption algorithm (NTRU) (LP #1863749)
      + d/control: mention plugins in package description
      + d/rules: enable ntru at build time
      + d/libstrongswan-extra-plugins.install: ship config and shared objects
    - Re-enable eap-{dynamic,peap} libcharon plugins (LP: 1878887)
      + d/control: update libcharon-extra-plugins description.
      + d/libcharon-extra-plugins.install: install .so and conf files.
      + d/rules: add plugins to the configuration arguments.
    - Remove conf files of plugins removed from libcharon-extra-plugins
      + The conf file of the following plugins were removed: eap-aka-3gpp2,
        eap-sim-file, eap-sim-pcsc, eap-sim, eap-simaka-pseudonym,
        eap-simaka-reauth, eap-simaka-sql, xauth-noauth.
      + Created d/libcharon-extra-plugins.maintscript to handle the removals
        properly.
  * Dropped changes:
    - Compile the tpm plugin against the tpm2 software stack (tss2).
      Merged in Debian (5.9.4-1).

Date: Fri, 12 Nov 2021 12:34:30 +0100
Changed-By: Paride Legovini <paride at ubuntu.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/+source/strongswan/5.9.4-1ubuntu1
-------------- next part --------------
Format: 1.8
Date: Fri, 12 Nov 2021 12:34:30 +0100
Source: strongswan
Built-For-Profiles: noudeb
Architecture: source
Version: 5.9.4-1ubuntu1
Distribution: jammy
Urgency: medium
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Paride Legovini <paride at ubuntu.com>
Changes:
 strongswan (5.9.4-1ubuntu1) jammy; urgency=medium
 .
   * Merge with Debian unstable. Remaining changes:
     - d/control: strongswan-starter hard-depends on strongswan-charon,
       therefore bump the dependency from Recommends to Depends. At the same
       time avoid a circular dependency by dropping
       strongswan-charon->strongswan-starter from Depends to Recommends as the
       binaries can work without the services but not vice versa.
     - re-add post-quantum encryption algorithm (NTRU) (LP #1863749)
       + d/control: mention plugins in package description
       + d/rules: enable ntru at build time
       + d/libstrongswan-extra-plugins.install: ship config and shared objects
     - Re-enable eap-{dynamic,peap} libcharon plugins (LP: 1878887)
       + d/control: update libcharon-extra-plugins description.
       + d/libcharon-extra-plugins.install: install .so and conf files.
       + d/rules: add plugins to the configuration arguments.
     - Remove conf files of plugins removed from libcharon-extra-plugins
       + The conf file of the following plugins were removed: eap-aka-3gpp2,
         eap-sim-file, eap-sim-pcsc, eap-sim, eap-simaka-pseudonym,
         eap-simaka-reauth, eap-simaka-sql, xauth-noauth.
       + Created d/libcharon-extra-plugins.maintscript to handle the removals
         properly.
   * Dropped changes:
     - Compile the tpm plugin against the tpm2 software stack (tss2).
       Merged in Debian (5.9.4-1).
Checksums-Sha1:
 9fa09c885fffb9ce17439b6611ac0ba5db6b0156 3125 strongswan_5.9.4-1ubuntu1.dsc
 4150773f9c06494bf64ce95446d4afa638f7727f 4651000 strongswan_5.9.4.orig.tar.bz2
 e67cb8781efdfe95c70d81c6f761b2b4db2de12b 127792 strongswan_5.9.4-1ubuntu1.debian.tar.xz
 1fb106972c1e5d2ba65606c1b113e0e02359a449 10592 strongswan_5.9.4-1ubuntu1_source.buildinfo
Checksums-Sha256:
 32a481010f49d1c9da81de69a37805c4d34143667ba81c6b7ba1fb0caf89a20c 3125 strongswan_5.9.4-1ubuntu1.dsc
 45fdf1a4c2af086d8ff5b76fd7b21d3b6f0890f365f83bf4c9a75dda26887518 4651000 strongswan_5.9.4.orig.tar.bz2
 441b0d4a58b52c9b275d1ec1ab9188cf463c1d3876debe4cdd2366d457961b9f 127792 strongswan_5.9.4-1ubuntu1.debian.tar.xz
 7cd99887435eadb361d052b486377ea401a99a591d2d44c444a5c2cf6ddf5868 10592 strongswan_5.9.4-1ubuntu1_source.buildinfo
Files:
 eb33e87ee718c3f4bdf5a82ab909111c 3125 net optional strongswan_5.9.4-1ubuntu1.dsc
 9c387eb77f0159fdefbcf7e81c905c35 4651000 net optional strongswan_5.9.4.orig.tar.bz2
 bfdde6a581d2ef211578031897acd4ac 127792 net optional strongswan_5.9.4-1ubuntu1.debian.tar.xz
 b70517abbf413b1d7bc334d15bccce7b 10592 net optional strongswan_5.9.4-1ubuntu1_source.buildinfo
Original-Maintainer: strongSwan Maintainers <pkg-swan-devel at lists.alioth.debian.org>
Vcs-Git: https://git.launchpad.net/~paride/ubuntu/+source/strongswan
Vcs-Git-Ref: refs/heads/merge-5.9.4-1-JAMMY
Vcs-Git-Commit: 577790f58fac4374a6598a10944da89f26db810e


More information about the jammy-changes mailing list