[ubuntu/jammy-proposed] libgcrypt20 1.9.4-3ubuntu2 (Accepted)

Dimitri John Ledkov dimitri.ledkov at canonical.com
Mon Nov 1 16:41:16 UTC 2021


libgcrypt20 (1.9.4-3ubuntu2) jammy; urgency=medium

  * Cherry-pick upstream patch to fix FTBFS on armhf.

libgcrypt20 (1.9.4-3ubuntu1) jammy; urgency=medium

  * Merge from Debian unstable. Remaining changes:
    - Disable the library reading /proc/sys/crypto/fips_enabled file
      and going into FIPS mode. libgcrypt is not a FIPS certified library.
      (LP 1748310)
  * Drop CVE and CET patches, applied in Debian or upstreamed.
  * Cherry-pick one more patch from master to correctly enable assembly
    CET.

libgcrypt20 (1.9.4-3) unstable; urgency=medium

  * Fix libgcrypt-config wrapper to use 'command -v' instead of 'which'.
    (Thanks, Emmanuel Bouthenot)
    Closes: #993244

libgcrypt20 (1.9.4-2) unstable; urgency=medium

  * Upload to unstable.

libgcrypt20 (1.9.4-1) experimental; urgency=medium

  * New upstream release. (Also includes fix for Elgamal encryption for
    other implementations. CVE-2021-33560)

libgcrypt20 (1.9.3-1) experimental; urgency=medium

  * New upstream release.

libgcrypt20 (1.9.2-1) experimental; urgency=low

  * New upstream release.

libgcrypt20 (1.9.2~beta16-1) experimental; urgency=low

  * Simplify ./configure for Windows build, do not disable optimization and
    assembly, set timestamp=$(SOURCE_DATE_EPOCH) instead of disabling the
    timestamp.
  * New upstream release.
    + Drop 30_Revert-Define-HW-feature-flags-per-architecture.patch.

libgcrypt20 (1.9.1-1) experimental; urgency=low

  * Add Bug-Database and Bug-Submit to upstream/metadata.
  * New upstream version.
    + Fixes heap buffer overflow introduced in 1.9.0.
      https://dev.gnupg.org/T5275. CVE-2021-3345 Closes: #981336
  * 30_Revert-Define-HW-feature-flags-per-architecture.patch Fix w* build
    error.

libgcrypt20 (1.9.0-1) experimental; urgency=low

  * New upstream version.
   + Drop 13_lessdeps_libgcrypt-pkgconfig.diff
   + Update 25_norevisionfromgit.diff.
   + List new symbols, bump all version requirements in libgcrypt20.symbols.
     (New args for gcry_control, new algorithms.)
   + Update copyright file.
   + Update algorithm list in package descriptions.

libgcrypt20 (1.8.7-6) unstable; urgency=medium

  * Update from LIBGCRYPT-1.8-BRANCH:
    + 30_10-cipher-Fix-ElGamal-encryption-for-other-implementati.patch
      CVE-2021-33560

Date: Mon, 01 Nov 2021 16:25:14 +0000
Changed-By: Dimitri John Ledkov <dimitri.ledkov at canonical.com>
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
https://launchpad.net/ubuntu/+source/libgcrypt20/1.9.4-3ubuntu2
-------------- next part --------------
Format: 1.8
Date: Mon, 01 Nov 2021 16:25:14 +0000
Source: libgcrypt20
Built-For-Profiles: noudeb
Architecture: source
Version: 1.9.4-3ubuntu2
Distribution: jammy
Urgency: medium
Maintainer: Ubuntu Developers <ubuntu-devel-discuss at lists.ubuntu.com>
Changed-By: Dimitri John Ledkov <dimitri.ledkov at canonical.com>
Closes: 981336 993244
Changes:
 libgcrypt20 (1.9.4-3ubuntu2) jammy; urgency=medium
 .
   * Cherry-pick upstream patch to fix FTBFS on armhf.
 .
 libgcrypt20 (1.9.4-3ubuntu1) jammy; urgency=medium
 .
   * Merge from Debian unstable. Remaining changes:
     - Disable the library reading /proc/sys/crypto/fips_enabled file
       and going into FIPS mode. libgcrypt is not a FIPS certified library.
       (LP 1748310)
   * Drop CVE and CET patches, applied in Debian or upstreamed.
   * Cherry-pick one more patch from master to correctly enable assembly
     CET.
 .
 libgcrypt20 (1.9.4-3) unstable; urgency=medium
 .
   * Fix libgcrypt-config wrapper to use 'command -v' instead of 'which'.
     (Thanks, Emmanuel Bouthenot)
     Closes: #993244
 .
 libgcrypt20 (1.9.4-2) unstable; urgency=medium
 .
   * Upload to unstable.
 .
 libgcrypt20 (1.9.4-1) experimental; urgency=medium
 .
   * New upstream release. (Also includes fix for Elgamal encryption for
     other implementations. CVE-2021-33560)
 .
 libgcrypt20 (1.9.3-1) experimental; urgency=medium
 .
   * New upstream release.
 .
 libgcrypt20 (1.9.2-1) experimental; urgency=low
 .
   * New upstream release.
 .
 libgcrypt20 (1.9.2~beta16-1) experimental; urgency=low
 .
   * Simplify ./configure for Windows build, do not disable optimization and
     assembly, set timestamp=$(SOURCE_DATE_EPOCH) instead of disabling the
     timestamp.
   * New upstream release.
     + Drop 30_Revert-Define-HW-feature-flags-per-architecture.patch.
 .
 libgcrypt20 (1.9.1-1) experimental; urgency=low
 .
   * Add Bug-Database and Bug-Submit to upstream/metadata.
   * New upstream version.
     + Fixes heap buffer overflow introduced in 1.9.0.
       https://dev.gnupg.org/T5275. CVE-2021-3345 Closes: #981336
   * 30_Revert-Define-HW-feature-flags-per-architecture.patch Fix w* build
     error.
 .
 libgcrypt20 (1.9.0-1) experimental; urgency=low
 .
   * New upstream version.
    + Drop 13_lessdeps_libgcrypt-pkgconfig.diff
    + Update 25_norevisionfromgit.diff.
    + List new symbols, bump all version requirements in libgcrypt20.symbols.
      (New args for gcry_control, new algorithms.)
    + Update copyright file.
    + Update algorithm list in package descriptions.
 .
 libgcrypt20 (1.8.7-6) unstable; urgency=medium
 .
   * Update from LIBGCRYPT-1.8-BRANCH:
     + 30_10-cipher-Fix-ElGamal-encryption-for-other-implementati.patch
       CVE-2021-33560
Checksums-Sha1:
 f6c5c5db0029e35686015c8ef82a1ea334f404fb 2907 libgcrypt20_1.9.4-3ubuntu2.dsc
 1bccc8393482fa1953323ff429c6b5ba5676eb1a 3239704 libgcrypt20_1.9.4.orig.tar.bz2
 5e9544f6a08ae92c9142f8e70dae3a99b13f83cc 228 libgcrypt20_1.9.4.orig.tar.bz2.asc
 b4fc80052f0690c626d8b11dbe31d95b58e76110 35104 libgcrypt20_1.9.4-3ubuntu2.debian.tar.xz
 ab5189b54f5bf0d1d418ce22aa2ec8241c169536 8713 libgcrypt20_1.9.4-3ubuntu2_source.buildinfo
Checksums-Sha256:
 d6d0e1a2711610994d34d397e70b624b624d059554b1cd82cd78896150a8bec2 2907 libgcrypt20_1.9.4-3ubuntu2.dsc
 ea849c83a72454e3ed4267697e8ca03390aee972ab421e7df69dfe42b65caaf7 3239704 libgcrypt20_1.9.4.orig.tar.bz2
 aa44cb00b779b4e75f3e63abeedd4112b10b4b92914dad8f23438fd0217a9fec 228 libgcrypt20_1.9.4.orig.tar.bz2.asc
 d0c2318dd7f3037e4c57e8e5b945e3ff2ff143ab11c5ad1cef050025b95bae53 35104 libgcrypt20_1.9.4-3ubuntu2.debian.tar.xz
 266af56a286f800fa17968cbb73d1bfb0176a4dd9d080e5af2d49700145d36e9 8713 libgcrypt20_1.9.4-3ubuntu2_source.buildinfo
Files:
 26ad98d1ef49e9c26dfbd60e4954cbaa 2907 libs optional libgcrypt20_1.9.4-3ubuntu2.dsc
 edc7becfe09c75d8f95ff7623e40c52e 3239704 libs optional libgcrypt20_1.9.4.orig.tar.bz2
 3870f2c741a18c9a4894480772975594 228 libs optional libgcrypt20_1.9.4.orig.tar.bz2.asc
 f97371825eccb663760e0a59d7132531 35104 libs optional libgcrypt20_1.9.4-3ubuntu2.debian.tar.xz
 ec1156f0907b00e00ca12e880a981761 8713 libs optional libgcrypt20_1.9.4-3ubuntu2_source.buildinfo
Original-Maintainer: Debian GnuTLS Maintainers <pkg-gnutls-maint at lists.alioth.debian.org>


More information about the jammy-changes mailing list